Bug 20288 - Helix gnome on 6.2 updated to 7.0
Helix gnome on 6.2 updated to 7.0
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
7.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-03 11:14 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-03 11:53:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-03 11:14:42 EST
I upgraded from 6.2 that was runig helix gnome and the install went fine 
but after the reboot I cannot login. The login screen is a cobination of 
he helix gnome and redhat login screen. While this is very tough toread I 
ca mange to enter my name and password. However no matter which uer [root 
included] it keeps dumping me backot the login screen as if I have entered 
in something incorrectly.
Comment 1 Havoc Pennington 2000-11-03 13:49:17 EST
We can't support Helix GNOME; there are dozens of possible package sets from
Helix that you could have installed. We can't possibly reproduce the state of
your system in order to diagnose the problem. We did try to make the upgrade
from Helix to 7.0 work, but we couldn't test anything like all the possible
Helix releases since they have such frequent updates.

To help you try and resolve it: have a look in ~/.xsession-errors after a failed
login attempt, and see what errors are there. In general I'd suggest a "pure"
install with all Helix or all Red Hat packages, try to get rid of all packages
from one or the other, and it should work.

Good luck.
Comment 2 Need Real Name 2000-11-03 14:15:55 EST
the only problem is that i am unable to get into my system to view anything. I 
remember some sort of safe mode boot but am not sure how to do that. I will try 
and contact helix
Comment 3 Havoc Pennington 2000-11-03 14:27:11 EST
Try flipping to a virtual console with Ctrl-Alt-F1 to log in and check out
.xsession-errors.
Comment 4 Need Real Name 2000-11-03 14:29:46 EST
but since i cannot logon won't i be unable to see anything? this seems like a 
catch 22
Comment 5 Havoc Pennington 2000-11-03 14:47:54 EST
The text console should let you log in, at least as root. If not, something is
seriously wrong, probably something unrelated to GNOME.
Comment 6 Need Real Name 2000-11-06 08:00:27 EST
I have stopped x from starting upon boot and then am able to logon and start x. 
However, the x system is unusable. The windows transparent so i see th 
background or any other windows that may be open. Also i have tried Helix-
Gnome,Enlightenment, KDE and I still have the same result. So as it stand the 
installation of rh7 had mande ALL of the possible desktops unusable. This fact 
stated it appears that rh7 upgrade is the cause or catalyst of this problem.
Comment 7 Havoc Pennington 2000-11-06 08:20:38 EST
Have you tried looking at ~/.xsession-errors after a failed login yet? What
messages are in that file?
Comment 8 Need Real Name 2000-11-06 08:52:12 EST
there is a problem viewing the hidden files. i have not figured it out yet. I 
have stayed away from that sine the problem spread past the login
Comment 9 Need Real Name 2000-11-06 23:05:57 EST
i iwas barely able to view the the error file and all teh messages are the 
same "Gdk-WARNING ** locale not supported by C library."
AS I have mentioned before this happen in ALL x sessions. 
Comment 10 Havoc Pennington 2000-11-07 00:01:46 EST
No useful messages there then; it's anyone's guess what's wrong. The state of
the machine is just messed up somehow. You might look around /var/log/ for
messages in the logfiles; if you don't know anyone who can poke around the
machine for you and look for the problem, the simplest solution is likely to
just reinstall the operating system so that you have straight Helix or straight
Red Hat packages and no other modifications.

Note You need to log in before you can comment on or make changes to this bug.