Bug 2028811 - issues with webp images
Summary: issues with webp images
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tellico
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: José Matos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-03 12:22 UTC by mark preston
Modified: 2021-12-12 01:10 UTC (History)
2 users (show)

Fixed In Version: tellico-3.4.2-2.fc34 tellico-3.4.2-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-12-12 01:05:11 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 445730 0 NOR RESOLVED issues with webp images 2021-12-03 12:22:31 UTC

Description mark preston 2021-12-03 12:22:32 UTC
SUMMARY
***
I have a comic collection and save images from https://marvel.fandom.com.  most are still jpgs but a newer format webp is becoming more common on here and tellico doesn't always display this image type correctly.
***


STEPS TO REPRODUCE
1. create a comic entry 
2. in a browser "save image as" from one of the images on this page: https://marvel.fandom.com/wiki/Strange_Academy_Vol_1
3. load the image into the comic entry. 

OBSERVED RESULT
When on the main page and you select the comic with a webp image it will not display in the entry details.
But if you "edit" the entry then you can see the image.
Also in reports with images they will not display in tellico but if you save it as HTML report and open in
a browser it is fine.

EXPECTED RESULT
should be able to display webp images along with jpg images

SOFTWARE/OS VERSIONS:fedora 34
Operating System: Fedora 34
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.14.14-200.fc34.x86_64 (64-bit)
Graphics Platform: X11
Processors: 4 × AMD FX-8370E Eight-Core Processor
Graphics Processor: llvmpipe

Comment 1 mark preston 2021-12-03 12:23:35 UTC
per KDE bug https://bugs.kde.org/show_bug.cgi?id=445730

Entry:  Robby Stephenson 2021-12-03 02:52:36 UTC 

KHTML doesn't support webp (and won't in the future since it's deprecated). If Fedora switches to using the QWebEngine support in Tellico, then webp images would work, I believe. If possible, I suggest you file a wishlist against Fedora. They'll need to make an update similar to what is shown for OpenSuse in this commit
https://www.mail-archive.com/commit@lists.opensuse.org/msg09940.html

Comment 2 Fedora Update System 2021-12-03 23:09:26 UTC
FEDORA-2021-6108ede740 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-6108ede740

Comment 3 Fedora Update System 2021-12-03 23:10:06 UTC
FEDORA-2021-9a9f4796c5 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-9a9f4796c5

Comment 4 José Matos 2021-12-03 23:13:23 UTC
(In reply to mark preston from comment #1)
> per KDE bug https://bugs.kde.org/show_bug.cgi?id=445730
> 
> Entry:  Robby Stephenson 2021-12-03 02:52:36 UTC 
> 
> KHTML doesn't support webp (and won't in the future since it's deprecated).
> If Fedora switches to using the QWebEngine support in Tellico, then webp
> images would work, I believe. If possible, I suggest you file a wishlist
> against Fedora. They'll need to make an update similar to what is shown for
> OpenSuse in this commit
> https://www.mail-archive.com/commit@lists.opensuse.org/msg09940.html

Please test the update to see if the issue is fixed for you in the above updates.

I took the opportunity and I have rebuild tellico with support for graphical chart reports as well.

Comment 5 Fedora Update System 2021-12-04 01:23:59 UTC
FEDORA-2021-6108ede740 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-6108ede740`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-6108ede740

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-12-04 02:17:05 UTC
FEDORA-2021-9a9f4796c5 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-9a9f4796c5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-9a9f4796c5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-12-12 01:05:11 UTC
FEDORA-2021-9a9f4796c5 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2021-12-12 01:10:12 UTC
FEDORA-2021-6108ede740 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.