Bug 2028968 - Whereabouts should reconcile stranded IP addresses
Summary: Whereabouts should reconcile stranded IP addresses
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.10
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.z
Assignee: Douglas Smith
QA Contact: Weibin Liang
URL:
Whiteboard:
Depends On: 2028967
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-03 20:30 UTC by Douglas Smith
Modified: 2022-02-25 01:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Implements an IP reconciliation job for Whereabouts IPAM CNI called "ip-reconciler" which runs as a Kubernetes cronjob. Reason: On occasion events occur where the CNI DEL action will not complete for a given pod (for example, a forcefully powered off node), and in such a case stored IP address allocations may be left stranded and unable to be allocated without manual intervention. Result: Stranded IP address allocations are garbage collected automatically on a periodic basis to free unused IP addresses.
Clone Of: 2028967
Environment:
Last Closed: 2022-02-25 01:38:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift whereabouts-cni pull 80 0 None open Bug 2028968: Whereabouts should reconcile IP addresses [backport 4.6] 2022-02-02 19:26:46 UTC
Red Hat Product Errata RHBA-2022:0566 0 None None None 2022-02-25 01:38:46 UTC

Description Douglas Smith 2021-12-03 20:30:03 UTC
+++ This bug was initially created as a clone of Bug #2028967 +++

+++ This bug was initially created as a clone of Bug #2028966 +++

+++ This bug was initially created as a clone of Bug #2028964 +++

+++ This bug was initially created as a clone of Bug #2028963 +++

Description of problem: IP reconciliation is a feature in the latest whereabouts, and due to reports, this feature should be backported all the way to 4.6.z. The feature is in the form of a cron job which reconciles the IP addresses.


Version-Release number of selected component (if applicable): 4.6-4.10


How reproducible: Specialized. Customers often experience this when nodes are rebooted, or pods are force deleted, and therefore CNI DEL calls aren't processed in their entirety by Whereabouts


Steps to Reproduce: (We will produce a procedure which produces orphaned IP addresses)

Actual results: IP addresses will remain stranded, and never utilized again.


Expected results: IP addresses that were stranded become available for use again.


Additional info: 4.10 has the reconciliation code but still requires a bug fix from upstream.

Comment 1 Weibin Liang 2022-02-03 16:22:47 UTC
Using cluster-bot to create a testing cluster:launch openshift/whereabouts-cni#80,openshift/cluster-network-operator#1267

Verified in 4.6.0-0.ci.test-2022-02-03-143529-ci-ln-qt43zk2-latest

Comment 6 errata-xmlrpc 2022-02-25 01:38:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.55 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0566


Note You need to log in before you can comment on or make changes to this bug.