Bug 2028991 - Insert > Object > QR Code = nothing
Summary: Insert > Object > QR Code = nothing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2029219
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-03 23:42 UTC by mark preston
Modified: 2021-12-25 01:04 UTC (History)
4 users (show)

Fixed In Version: libreoffice-7.2.4.1-2.fc36 libreoffice-7.2.4.1-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-12-25 01:04:55 UTC
Type: Bug


Attachments (Terms of Use)

Description mark preston 2021-12-03 23:42:28 UTC
Description of problem:
after upgrading Fedora from 34 to 35 via DNF, libreoffice 
Insert > Object > QR Code
does nothing.  no pop up window, no errors, just a noopt


Version-Release number of selected component (if applicable):
fedora35

How reproducible:
I've repeated this on 2 different systems upgraded from 34 to 35.


Steps to Reproduce:
1.using Fedora 34 install libreoffice and in writer do a 
Insert > Object > QR Code and a popup option box opens
so you can do the insert.

2. then Upgrade Fedora to 35 using DNF method

3. start libreoffice writer and do a 
Insert > Object > QR Code  and you get nothing.



Actual results:
no qr code popup options box

Expected results:
A qr code popup options box

Additional info:
using libreoffice packages that are in the fedora repository, NOT using version from LibreOffice

Comment 1 Caolan McNamara 2021-12-04 11:05:33 UTC
we don't have zxing-cpp (which libreoffice currently requires for this feature) in fedora so this seems to be why this doesn't work, we would need to add that

Comment 2 Fedora Update System 2021-12-14 03:30:24 UTC
FEDORA-2021-b44230c684 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2021-b44230c684

Comment 3 Fedora Update System 2021-12-14 03:41:11 UTC
FEDORA-2021-b44230c684 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 4 mark preston 2021-12-14 13:09:33 UTC
Hi,
i'm having to reopen this as i filed this on Fedore 35, not Fedora 36 and i do not see a package for 35.  36 hasn't been released yet.  Please provide a package for 35.

Comment 5 Caolan McNamara 2021-12-14 14:12:45 UTC
its the automated tooling that closes these when the bug id appears in an update. There will be a F35 update of LibreOffice when zxing become available to build against in F35.
https://bodhi.fedoraproject.org/updates/FEDORA-2021-ed9f8e5aba

Comment 6 Fedora Update System 2021-12-23 19:30:34 UTC
FEDORA-2021-a610f6fb90 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a610f6fb90

Comment 7 Fedora Update System 2021-12-24 02:05:06 UTC
FEDORA-2021-a610f6fb90 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-a610f6fb90`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-a610f6fb90

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2021-12-25 01:04:55 UTC
FEDORA-2021-a610f6fb90 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.