Bug 202904 - Anaconda load failure with bug report
Anaconda load failure with bug report
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-16 19:42 EDT by Paul Norris
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 19:49:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda bug report (53.53 KB, text/plain)
2006-08-16 19:42 EDT, Paul Norris
no flags Details

  None (edit)
Description Paul Norris 2006-08-16 19:42:15 EDT
Description of problem:

Fc5 failed to install near final installation. Bug report issued by anaconda
attached
Version-Release number of selected component (if applicable):
FC5

How reproducible:


Steps to Reproduce:
1.Booting from FC5-i386-disk1 downloaded last night.
2.Installation proceeded to final installation phase.
3.Anaconda issued bug text. 
  
Actual results:
Failed to install!

Expected results:
Final installation

Additional info:I'm not skilled enough to understand the bug report!Help wanted.
Comment 1 Paul Norris 2006-08-16 19:42:15 EDT
Created attachment 134356 [details]
Anaconda bug report
Comment 2 Andre Robatino 2006-08-17 17:07:07 EDT
  Before this bug is closed as NOTABUG (due to the error message coming from the
CD drive masquerading as a hardware bug) I should mention that I've also
experienced this problem, and that the same machine, after repeated failed
installs of FC5, installed FC4 with no problems on the first try.  There have
been many reports of this type associated with FC5, and it's just not plausible
that all these machines suddenly started having hardware problems when FC5 came
out, and that the problem goes away when FC4 is installed.
Comment 3 Paul Norris 2006-08-17 17:59:10 EDT
Thanks Andre for comments. Can you please advise me how you reached your
conclusion? I'm reasonably skilled in plain vanilla software (Pascal prefered!)
but as I'm only just trying to convert to Linux and I haven't yet discovered the
delights of the Source code (if its written in C, I'm all at sea). If assembler
I might be able to follow the logic slowly. The disk unit in question is an LG
DRD-8160B DVD-ROM or the GCE-8160B CD-Rewriter).  I'm trying to convert my old
PII-400 on Intel SR440BX MB, 256 Ram and 8GB disk into something useful. XP will
not run and W98 is now to claggy (and unsupported)! Unfortunately will not
support the DVD to boot so have to use the CD to load.
Thanks again Paul N
Comment 4 Andre Robatino 2006-08-17 18:12:13 EDT
  The messages I'm referring to are

<4>hdc: command error: status=0x51 { DriveReady SeekComplete Error }
<4>hdc: command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
<4>ide: failed opcode was: unknown
<4>end_request: I/O error, dev hdc, sector 588
<3>Buffer I/O error on device hdc, logical block 147

where hdc is

<4>hdc: LG DVD-ROM DRD-8160B, ATAPI CD/DVD-ROM drive

There have been many bug reports of this type and the above messages are always
interpreted as meaning that there's a hardware problem with the drive, and the
bug is closed.  The problem, as I said above, is that it only affects a FC5
install.  You could probably try to install FC5 10 times, each time having the
same problem, then install FC4 successfully on the first try.  It's not the
hardware, no matter how much it looks like it.
Comment 5 Paul Norris 2006-08-17 19:17:35 EDT
Thanks for info. I've just spent a fruitless 30 mins trying to find an FC4
Download site on Fedora Wiki. It seems to have been wiped from the face of the
earth!
I do have a bootable Core1 that came with the "Linux for Dummies" (that my level
at the moment. I suppose that might be better than nix. However I thought that
newer releases would be better!
thanks Paul
Comment 6 Andre Robatino 2006-08-18 05:30:18 EDT
  You should try installing from your other drive (the GCE-8160B) if you're
using CDs (you may have to make this drive bootable in your BIOS), or if you
have broadband, you could try a network install.  FC5 is definitely an
improvement over FC4 IF you can install it.
Comment 7 Andre Robatino 2006-08-18 05:40:24 EDT
  I should also mention that I was able to install on my problem machine after
temporarily putting in a different drive.  So you would have a decent chance of
success using your other drive.
Comment 8 Paul Norris 2006-08-19 17:06:33 EDT
Thanks for help.
spent six hours down-loading fc-4-i386-DVD.iso which my machine would not accept
as a boot disk!Disk E is the DVD-ROM and is IDE Master. System would only boot
of CD-ROM in that disk. So loaded fc-5-i386-disk1.iso using "Linux askmethod".
Selected CDROM option and put disk1 in Drive F, the CD-ROM and IDE Slave and off
it went. Now have FC-5 installed so I can start learning about Linux.
General comment, the loader asks all sort of questions which assume a fairly
deep knowledge of the system before you can even start! eg how Linux identifies
disk partions and what a root is! Still some way to go yet before loading Fedora
Linux is as simple as loading Windows. Admittedly since I had a dual system made
it more complex but I now have Linux and Windows98 together (XP would not touch
this machine as it's only a PII/400 with 256MB ram and 8GB disk.
Do I have to report that it failed to run the on-board sound chip? it's a Sound
Blaster AudioPCI 64V PC98 compliant.
Please advise  Paul Norris
Comment 9 Andre Robatino 2006-08-19 17:16:32 EDT
  You'll have to google or search Bugzilla for this problem; I'm not familiar
with that hardware but it's probably been reported before.  Good luck.
Comment 10 Jeremy Katz 2006-08-22 19:49:53 EDT
That message is always caused by a failing hardware component somewhere.  While
sometimes it will work with other versions or distributions, that just ends up
meaning that the timing is marginally better and thus doesn't tickle a) bad
drive/media interactions b) cable problems or c) other small hardware issues
Comment 11 Andre Robatino 2006-08-23 04:32:03 EDT
  I have an eMachine with a Samsung SCR-3232 CD-ROM drive, and my father has two
similar eMachines, both with Samsung SCR-2432 drives.  All 3 machines could
install FC4 successfully, none could install FC5 using the original drives,
though the type of media used was exactly the same before and after in each
case.  Since the drives are clearly physically capable of reading the media, the
sudden inability to read it properly with the FC5 installer must be the
installer's fault.  Well-written drivers are supposed to do the best possible
job of making use of the hardware, (_even if it's flaky_), which isn't happening
here.

Note You need to log in before you can comment on or make changes to this bug.