Bug 202925 - wrong rendering of Japanese combining characters
wrong rendering of Japanese combining characters
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-17 04:53 EDT by Akira TAGOH
Modified: 2009-02-25 04:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 04:43:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (47.69 KB, image/png)
2006-08-17 04:53 EDT, Akira TAGOH
no flags Details
testcase (36 bytes, text/plain)
2006-08-17 04:57 EDT, Akira TAGOH
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 139950 None None None Never

  None (edit)
Description Akira TAGOH 2006-08-17 04:53:20 EDT
Description of problem:
OS X deals with the (semi-)voiced consonant using the combining (semi-)voiced
sound mark(U+3099 and U+309A) in Japanese instead of already combined characters. 
So it may be likely to see such documents on even Linux Desktop so that users
may wants to exchange the files between both environments.
When it appears in text, Pango can deal with it as one character for editing.
but obviously it's too larger and it looks like two characters are there then.

Version-Release number of selected component (if applicable):
pango-1.14.0-2

How reproducible:
always

Steps to Reproduce:
1.open a sample file on gedit say
2.
3.
  
Actual results:
looks like a screenshot

Expected results:
should be rendered similarly with the combined character

Additional info:
Comment 1 Akira TAGOH 2006-08-17 04:53:22 EDT
Created attachment 134370 [details]
screenshot
Comment 2 Akira TAGOH 2006-08-17 04:57:25 EDT
Created attachment 134371 [details]
testcase
Comment 3 Liang Zhang 2006-09-06 22:14:28 EDT
the same bug of upsteam:
http://bugzilla.gnome.org/show_bug.cgi?id=354712
Comment 4 Bug Zapper 2008-05-13 22:17:17 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Tony Fu 2008-09-09 23:06:29 EDT
requested by Jens Petersen (#27995)
Comment 6 lexual 2009-02-25 04:43:40 EST
Thank you for the bug report. This particular bug has already been reported
to the author of the software, and the Fedora developers don't plan to work
on it at the moment. You can help out by adding any helpful additional
information you have to the upstream bug report at:
http://bugzilla.gnome.org/show_bug.cgi?id=139950

If you want to follow what happens to the bug, you can add yourself to the
upstream report.

Note You need to log in before you can comment on or make changes to this bug.