Bug 2029404 - X11 doesn't start in Fedora 35
Summary: X11 doesn't start in Fedora 35
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 35
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2021-12-06 12:10 UTC by Jukka Lahtinen
Modified: 2022-12-13 16:03 UTC (History)
0 users

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Last Closed: 2022-12-13 16:03:13 UTC
Type: Bug

Attachments (Terms of Use)
The Xorg.0.log file (23.37 KB, text/plain)
2021-12-06 12:10 UTC, Jukka Lahtinen
no flags Details
rpm package list (180.66 KB, text/plain)
2021-12-16 16:34 UTC, Jukka Lahtinen
no flags Details

Description Jukka Lahtinen 2021-12-06 12:10:05 UTC
Created attachment 1844895 [details]
The Xorg.0.log file

Created attachment 1844895 [details]
The Xorg.0.log file

Created attachment 1844895 [details]
The Xorg.0.log file

Description of problem:
Since I upgraded my secondary computer from Fedora 34 to 35 by dnf system-upgrade, I can't start x11 in it. I run on "runlevel 3", logging in to a text-mode virtual console, and start x11 with the startx command, and prefer to keep it that way. It worked before, but not with F35.
The computer is built in December 2009, it has an Intel processor with builtin graphics controller, and I use kde desktop. 
I am reluctant to upgrade my main computer to F35 before seeing this fixed, in case it will have the same problem.

Version-Release number of selected component (if applicable):
Fully upgraded Fedora 35

How reproducible:
Every time in my system.

Steps to Reproduce:
1. log in to the text mode virtual console
2. give the startx command

Actual results:
It just turns the screen black for a while, then returns to the text mode prompt showing the output below in "Additional info".

Expected results:
X11 running

Additional info:
This is what I see after the failed startx:

xauth:  file /home2/jukka/.serverauth.119602 does not exist

X.Org X Server 1.20.11
X Protocol Version 11, Revision 0
Build Operating System:  5.12.13-300.fc34.x86_64
Current Operating System: Linux ipa 5.15.4-201.fc35.x86_64 #1 SMP Tue Nov 23 18:54:50 UTC 2021 x86_64
Kernel command line: BOOT_IMAGE=(hd0,msdos7)/boot/vmlinuz-5.15.4-201.fc35.x86_64 root=UUID=06627239-ef9a-4642-bbd5-d5de29cc9366 ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True KEYTABLE=fi-latin1 rd.luks=0 LANG=en_US audit=0
Build Date: 23 July 2021  12:00:00AM
Build ID: xorg-x11-server 1.20.11-2.fc35
Current version of pixman: 0.40.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home2/jukka/.local/share/xorg/Xorg.0.log", Time: Mon Dec  6 14:02:40 2021
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
                                                                       (II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
                                                                                                                                       xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

Comment 1 Jukka Lahtinen 2021-12-16 16:34:11 UTC
Created attachment 1846626 [details]
rpm package list

Comment 2 Ben Cotton 2022-11-29 17:27:04 UTC
This message is a reminder that Fedora Linux 35 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora Linux 35 on 2022-12-13.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
'version' of '35'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, change the 'version' 
to a later Fedora Linux version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora Linux 35 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora Linux, you are encouraged to change the 'version' to a later version
prior to this bug being closed.

Comment 3 Ben Cotton 2022-12-13 16:03:13 UTC
Fedora Linux 35 entered end-of-life (EOL) status on 2022-12-13.

Fedora Linux 35 is no longer maintained, which means that it
will not receive any further security or bug fix updates. As a result we
are closing this bug.

If you can reproduce this bug against a currently maintained version of Fedora Linux
please feel free to reopen this bug against that version. Note that the version
field may be hidden. Click the "Show advanced fields" button if you do not see
the version field.

If you are unable to reopen this bug, please file a new report against an
active release.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.