Bug 202957 - window -> save text causes crash
window -> save text causes crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-08-17 10:28 EDT by Max Spevack
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-19 10:40:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Spevack 2006-08-17 10:28:29 EDT
Description of problem:

Run xchat.  Have a meeting.  Attempt to save the text from that meeting.

Window -> Save Text.

Program crashes.

Version-Release number of selected component (if applicable):
xchat-2.6.0-6

2.6.6 seems to be the latest upstream.
Comment 1 Matthias Clasen 2006-08-18 09:38:58 EDT
This is the dbus vs threads problem.

xchat tries to open a file chooser there, which uses gnome-vfs, which uses
dbus and threads, but dbus has already been initialized without threads
by a module earlier.

Fix will hopefully appear in dbus soon.
Comment 2 Matthias Clasen 2006-08-19 10:40:30 EDT
fix is in dbus-0.92-1

Note You need to log in before you can comment on or make changes to this bug.