Bug 202968 - update to current caching nameserver breaks NetworkManager
update to current caching nameserver breaks NetworkManager
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: caching-nameserver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-17 11:21 EDT by Bill Nottingham
Modified: 2014-03-16 23:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-13 08:16:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-08-17 11:21:16 EDT
Description of problem:

I upgraded to rawhide today, this installed:

caching-nameserver-9.3.2-37.fc6

Immediately, NetworkManager's nameserver broke, and restarting either named or
NM did not fix it.

I eventually just edited /etc/resolv.conf so I could get things done.
Comment 1 David Lawrence 2006-08-17 11:34:39 EDT
I have observed this behaviour as well. But rather than editing
/etc/resolv.conf, I have found /sbin/service named stop works as well. When
stopping, real values are written to resolv.conf automatically instead of the
127.0.0.1 that NetworkManager installs.
Comment 2 Martin Stransky 2006-09-14 05:52:36 EDT
If you don't restart named manually, which networks aren't available? Could you
attach bind configuration?
Comment 3 Bill Nottingham 2006-09-14 15:12:46 EDT
At this point, it's been reinstalled twice and NM has been downgraded. Not sure
I can reproduce.
Comment 4 Martin Stransky 2006-09-18 10:58:42 EDT
How many network devices do you have? Do you use any VPN?
Comment 5 Bill Nottingham 2006-09-18 13:17:26 EDT
Wired and wireless, although only one is ever active at a time. Yes, I use VPN,
(NM-vpnc) and I believe it was up at the time.
Comment 6 Martin Stransky 2006-09-19 08:32:31 EDT
okay, and do you have still this problem or it appeared only after the upgrade?
It's probably a variant of #203291 or #196962
Comment 7 Bill Nottingham 2006-09-19 10:51:19 EDT
Haven't seen it since then, no.

Note You need to log in before you can comment on or make changes to this bug.