Bug 203011 - RFE: allow daemon() in /etc/init.d/functions to pass -m to /sbin/runuser
RFE: allow daemon() in /etc/init.d/functions to pass -m to /sbin/runuser
Status: CLOSED DUPLICATE of bug 203010
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-17 15:24 EDT by Japheth Cleaver
Modified: 2014-03-16 23:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 15:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Japheth Cleaver 2006-08-17 15:24:16 EDT
Description of problem:
When running the daemon() function from an initscript and using the "--user" 
option, daemon will run "/sbin/runuser" to execute. This command clears the 
environment by default unless the -m or -p arguments are given. This can create 
a problem because some initscripts set environment variables for their 
programs' use.


Version-Release number of selected component (if applicable):
FC5+

How reproducible:
Always.

Steps to Reproduce:
1. Export a variable in an initscript which sources /etc/init.d/functions
2. call a program using the "daemon --user BLAH program" syntax
  
Actual results:
The variable you exported will not be present in the program's environment.

Expected results:
That the variable would be available, yo, regardless of the fact that we're 
switching users.
Comment 1 Japheth Cleaver 2006-08-17 15:25:46 EDT

*** This bug has been marked as a duplicate of 203010 ***

Note You need to log in before you can comment on or make changes to this bug.