Bug 203050 - gnucash 2.0: Finance::Quote Module not installed properly
gnucash 2.0: Finance::Quote Module not installed properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-17 20:50 EDT by Greg Douglas
Modified: 2014-03-16 23:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 16:06:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Douglas 2006-08-17 20:50:28 EDT
Description of problem:

I've been trying the 2.0 release of gnucash located in Testing, and have come
across the following bug when attempting to automatically update the price of a
security. Here is a related thread over at gnucash:
http://lists.gnucash.org/pipermail/gnucash-user/2006-July/017022.html


According to the Gnucash readme file, a user is supposed to run the script
"update-finance-quote" as su in order to get the latest perl modules, but I
cannot locate this script.


Version-Release number of selected component (if applicable): 2.0.0


How reproducible: Every Time


Steps to Reproduce:
1. Open a security in Edit mode, and the warning appears in the lower half of
the dialog box.
2.
3.
  
Actual results:
the warning message "Warning: Finance::Quote Module not installed properly"
appears at the lower half of the dialog box, and the automatic update options
are grayed out.


Expected results:
Ability to update the security price.

Additional info:
Comment 1 Bill Nottingham 2006-08-17 22:13:07 EDT
Hm, that readme should probably be changed. Try 'yum install perl-Finanace-Quote'.
Comment 2 Greg Douglas 2006-08-18 09:56:10 EDT
Hi There.

I installed the perl-Finance-Quote package, and it still did not work.

I then tried running /usr/bin/gnc-fq-update as su, as instructed in the gnucash
user guide.  This did not complete successfully with an error code of 255.

I then tried to run /usr/bin/gnc-fq-dump to test the setup, and it complained
thet perl-Crypt-SSLeay is missing.

I then installed the package perl-Crypt-SSLeay.  The module now appears to be
correctly installed in Gnucash.

Should the RPMS now include dependancies for perl-Finance-Quote and
perl-Crypt-SSLeay?

Thanks.
Comment 3 Bill Nottingham 2006-08-22 16:06:32 EDT
Fixed (req for perl-Crypt-SSLeay) added in 2.0.1-4.fc6.

Note You need to log in before you can comment on or make changes to this bug.