Bug 203057 - GTK+ grabs keys for accelerator key before passing through IM
GTK+ grabs keys for accelerator key before passing through IM
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-17 23:43 EDT by Jong Bae KO
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 16:10:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 355364 None None None Never

  None (edit)
Description Jong Bae KO 2006-08-17 23:43:47 EDT
Description of problem:
When you create new mail, and you want to use Hanja in korean.
We type korean char and then press F9 for Hangul/Hanja converting.
It is working with Hangul/Hanja converting.
But, if you doesn't want convert after you press F9, you need to press ESC key.
when press ESC key it asks to kill new mail windows.


Version-Release number of selected component (if applicable):
evolution-2.7.4-4
scim-hangul-0.2.2-6.fc6
scim-1.4.4-29.fc6

How reproducible:
allways

Steps to Reproduce:
1. Turn on Hangul with SCIM in evolution
2. Make new mail.
3. type "rh"
4. press F9
5. press ESC key
  
Actual results:
cancel the new mail


Expected results:
cancel Hangul/Hanja convertion

Additional info:
Comment 1 Mayank Jain 2006-09-14 05:53:52 EDT
> Steps to Reproduce:
> 1. Turn on Hangul with SCIM in evolution
> 2. Make new mail.
> 3. type "rh"
> 4. press F9
> 5. press ESC key

Hi,

Using the following steps does not crashes or kills the composer window on
evolution-2.8.0-1.fc6

Can you please confirm the status of this bug?

Thanks :)
Mayank
Comment 2 Jong Bae KO 2006-09-14 20:23:49 EDT
Yes after press ESC key
It was asking me "Are you sure you want to discard the message".
Strange....
Did you type "rh" in Korean? Because steps 3 & 4 is converting korean to Chinese
char.

evolution-2.8.0-1.fc6
Comment 3 Mayank Jain 2006-09-15 08:34:20 EDT
Hi,
I still cannot reproduce this bug... 

This is *exactly* what I followed

- start evolution from en_US locale
- new > mail message
- focussed the composer - ascii mode
- activated scim, selected hangul
- pressed "rh" and then F9 to bring candidate selection window
- hit escape

Is it specific evolution? I mean with gedit/kedit/firefox whats the result? All
behave perfectly as expected for me.

Can you please attach a backtrace if its possible for you?

Please check the version of scim...
rpm -q scim scim-hangul
scim-1.4.4-34.fc6
scim-hangul-0.2.2-7.fc6

Thanks,
Mayank
Comment 4 Akira TAGOH 2006-09-15 09:38:10 EDT
apparently summary is misleading. read the original report carefully. it says
that Escape key should works to cancel the conversion instead of destroying the
composer window.  You can see the differenct behavior between evolution and
gedit say.

It won't asks you to discard editing unless you typed something on the composer
window once, because preediting doesn't makes any changes. therefore no
modifications yet.

This is because GTK+ grabs the key event in front if the applications sets any
keys as the accelerator keys. it really depends on the applications if this
happens or not though, actually this is a well-known GTK+ bug.
Comment 5 Akira TAGOH 2006-09-26 01:34:59 EDT
reassigning to gtk2 for the above reason.
Comment 6 Matthias Clasen 2006-09-26 01:53:31 EDT
"bug" is up for discussion. Well-known behaviour, yes.
Comment 7 Matthias Clasen 2006-10-16 16:10:03 EDT
Upstream bug tracking this is http://bugzilla.gnome.org/show_bug.cgi?id=90082

Note You need to log in before you can comment on or make changes to this bug.