Bug 2030592 - Keep QXL/SPICE support for RHEL 9
Summary: Keep QXL/SPICE support for RHEL 9
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: qemu-kvm
Version: 9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Uri Lublin
QA Contact: Guo, Zhiyi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-09 08:48 UTC by Rik Theys
Modified: 2022-07-13 23:11 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-06-20 07:53:40 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-105223 0 None None None 2021-12-09 08:53:48 UTC

Description Rik Theys 2021-12-09 08:48:36 UTC
Description of problem:

It seems RHEL 9 will no longer have support for QXL and spice console access. It seems it was deprecated with RHEL 8.3 and dropped in 9.0.

No reason why this was done is mentioned and I was unable to find the reason in other threads online.

We currently use oVirt to provide VDI access to students. Students need the ability to redirect USB devices to the virtual machines. This is supported by SPICE but not with VNC.

Spice graphics are also much more performant than VNC, so we are surprised this is being dropped.

What is the reason this support is being dropped? We would like Red Hat to reconsider this deprecation and continue to support QXL/SPICE in RHEL 9.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 John Ferlan 2021-12-09 11:40:52 UTC
Assigned to Meirav since her teams owns SPICE, but added Martin in a needinfo to give the product management perspective on the above.

Comment 2 lethalwp 2021-12-13 08:19:12 UTC
Adding my note:

I use virt-manager with spice every day for my work. I updated my laptop to centos9 stream and it broke my work setup. I was very surprised on this deprecated feature, removed with no explanation.
Maybe Centos9stream isn't the OS that i need?


Luckily i have another working pc using fedora. I don't understand why spice is getting dropped while it is shipped & usable in fedora 35. I thought Centos was a "more stable" fork from fedora.
It seems it isn't the case.

Comment 3 Mai Ling 2022-05-20 14:26:19 UTC
Hello Redhat, any update on this?

Comment 4 Martin Tessun 2022-06-20 07:53:40 UTC
So in short:

SPICE has been deprecated for qemu and has been removed in RHEL 9. We still do have SPICE client support for RHV - which is shipped in the RHV-Tools repos on RHEL 9.
Unfortunately I don't know if and how oVirt is solving this for RHEL 9. Anyways the RHV-tools repo will be supported until RHV is EOLed in 2026.

Why no SPICE:
1. Due to some license restrictions around H.264 codecs we are not able to provide a Streaming solution which is needed for modern workloads (as all drivers are using 3D today). Also vGPU support is not possible without this.
2. There are quite some 3rd party solutions that already have a proper implementation (licensed software due to H.264 restrictions unfortunately).
3. For console access and local acceleration VNC is capable of doing the job - and VNC is also used for OpenStack and KubeVirt and they are both not interested in using SPICE instead.

Mainly due to (1) and (3) we decided to deprecate our work on SPICE.


Note You need to log in before you can comment on or make changes to this bug.