Bug 2031214 (F36Serverbootx86_64Oversize) - Fedora 36: Server boot x86_64 image exceeds maximum size
Summary: Fedora 36: Server boot x86_64 image exceeds maximum size
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: F36Serverbootx86_64Oversize
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F36BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2021-12-10 19:00 UTC by Fedora QA Tools SIG
Modified: 2022-02-17 16:19 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-17 16:19:39 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github weldr lorax pull 1213 0 None open cleanup: handle RPM database move to /usr 2022-02-03 23:25:48 UTC

Description Fedora QA Tools SIG 2021-12-10 19:00:55 UTC
Server boot x86_64 image https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20211210.n.0/compose/Server/x86_64/iso/Fedora-Server-netinst-x86_64-Rawhide-20211210.n.0.iso from compose Fedora-Rawhide-20211210.n.0 is 749731840 bytes, exceeding the maximum size 734003200. Canonical maximum sizes can be found at https://fedoraproject.org/wiki/Releases/36/Spins and https://fedoraproject.org/wiki/Releases/36/ReleaseBlocking . This check is run by the 'relval' tool, which has its own list of maximum sizes derived from those pages. If the maximum size used for this comparison is wrong, please add a comment and file a bug against relval at https://pagure.io/fedora-qa/relval/issues and it will be corrected. If you believe the canonical maximum size for an image should be changed, please follow the appropriate process before filing a relval bug.

Comment 1 Fedora QA Tools SIG 2021-12-15 19:17:30 UTC
Server boot x86_64 image https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20211215.n.0/compose/Server/x86_64/iso/Fedora-Server-netinst-x86_64-Rawhide-20211215.n.0.iso from compose Fedora-Rawhide-20211215.n.0 is 749731840 bytes, exceeding the maximum size 734003200.

Comment 2 Fedora QA Tools SIG 2021-12-29 23:26:44 UTC
Server boot x86_64 image https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20211229.n.1/compose/Server/x86_64/iso/Fedora-Server-netinst-x86_64-Rawhide-20211229.n.1.iso from compose Fedora-Rawhide-20211229.n.1 is 761266176 bytes, exceeding the maximum size 734003200.

Comment 3 Luna Jernberg 2022-01-10 16:17:36 UTC
Fedora-Rawhide-20211229.n.1 is 761266176 bytes, exceeding the maximum size 734003200.

Comment 4 Luna Jernberg 2022-01-10 16:18:34 UTC
(In reply to Luna Jernberg from comment #3)
> Fedora-Rawhide-20211229.n.1 is 761266176 bytes, exceeding the maximum size
> 734003200.

@adamw and @pboy is looking into this later this week

Comment 5 Adam Williamson 2022-01-10 16:20:29 UTC
Sigh, and the auto-blocking still isn't working. This is an automatic Beta blocker per https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Automatic_blockers , "Any release-blocking Beta or Final image exceeding its maximum size (failures of QA:Testcase_Mediakit_ISO_Size)".

Comment 6 Adam Williamson 2022-01-10 18:50:44 UTC
https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20220110.n.0/compose/Server/x86_64/iso/Fedora-Server-netinst-x86_64-Rawhide-20220110.n.0.iso is 767557632 , so this is just getting worse. I'll see if I can figure out what's going on.

Comment 7 Adam Williamson 2022-01-10 19:57:17 UTC
Here's a diff between the packages pulled into an F35 everything installer image, and the F36 server installer image (I don't have logs from an f35 server installer image). Left out some identity stuff which is just everything vs. server and 35 vs. rawhide.

+initscripts-service
-iptables-legacy-libs
-ipw2100-firmware
-ipw2200-firmware
+libbpf
+libffi3.1
+lilv
-logrotate
+lv2
+malcontent-libs
+openssl1.1
+python3-packaging
+python3-pyparsing
+serd
+sord
+sratom

I'll look into those and see how much of a problem each is, and why they're getting pulled in.

Comment 8 Adam Williamson 2022-01-10 20:13:38 UTC
Looks like none of those are very big. I think we're back in firmware hell here. It seems like Marvell Prestera firmwares aren't in a subpackage any more in the latest build, and maybe some other big firmwares got added. I'll dig into it and see what we can do here.

Comment 9 Adam Williamson 2022-01-10 22:57:38 UTC
OK, I sent a build of linux-firmware which corrects that problem:

https://koji.fedoraproject.org/koji/buildinfo?buildID=1876339

That probably doesn't account for *all* the bloat, but may get us back under the limit at least. I'll maybe see if I can find anything else after that.

Comment 11 Fedora QA Tools SIG 2022-02-03 00:48:54 UTC
Server boot x86_64 image https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20220202.n.1/compose/Server/x86_64/iso/Fedora-Server-netinst-x86_64-Rawhide-20220202.n.1.iso from compose Fedora-Rawhide-20220202.n.1 is 783286272 bytes, exceeding the maximum size 734003200.

Comment 12 Adam Williamson 2022-02-05 00:50:48 UTC
lorax 36.5 (36.6 is now tagged) should fix this the next time we get a successful compose.

Comment 13 Fedora QA Tools SIG 2022-02-05 11:08:49 UTC
Server boot x86_64 image https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20220205.n.1/compose/Server/x86_64/iso/Fedora-Server-netinst-x86_64-Rawhide-20220205.n.1.iso from compose Fedora-Rawhide-20220205.n.1 is 736100352 bytes, exceeding the maximum size 734003200.

Comment 14 Ben Cotton 2022-02-08 20:14:46 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 36 development cycle.
Changing version to 36.

Comment 15 Ben Cotton 2022-02-17 16:19:39 UTC
https://kojipkgs.fedoraproject.org/compose/branched/Fedora-36-20220216.n.0/compose/Server/x86_64/iso/Fedora-Server-netinst-x86_64-36-20220216.n.0.iso is 708837376 bytes, so the problem is fixed until the next time it's broken.


Note You need to log in before you can comment on or make changes to this bug.