Bug 2031228 (CVE-2021-43813) - CVE-2021-43813 grafana: directory traversal vulnerability
Summary: CVE-2021-43813 grafana: directory traversal vulnerability
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2021-43813
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2035270 2031781 2032175 2032740 2032741 2038410 2038411 2038418 2038419
Blocks: 2031229
TreeView+ depends on / blocked
 
Reported: 2021-12-10 19:36 UTC by Guilherme de Almeida Suckevicz
Modified: 2022-08-09 20:32 UTC (History)
39 users (show)

Fixed In Version: grafana 8.3.2, grafana 7.5.12
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-11 22:45:17 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2022:0056 0 None None None 2022-03-10 16:02:21 UTC
Red Hat Product Errata RHSA-2022:1781 0 None None None 2022-05-10 13:24:14 UTC
Red Hat Product Errata RHSA-2022:6024 0 None None None 2022-08-09 20:32:24 UTC

Description Guilherme de Almeida Suckevicz 2021-12-10 19:36:23 UTC
GitHub Security Labs notified us that there’s a limited directory traversal attack against Grafana 8.3.1 which allows access to '.md' files. During our internal follow-up investigation, we found an attack allowing access to `.csv` files. The vulnerable URL path is: '/api/plugins/.*/markdown/.*'

Comment 14 errata-xmlrpc 2022-03-10 16:02:18 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 4.10

Via RHSA-2022:0056 https://access.redhat.com/errata/RHSA-2022:0056

Comment 15 errata-xmlrpc 2022-05-10 13:24:11 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2022:1781 https://access.redhat.com/errata/RHSA-2022:1781

Comment 16 Product Security DevOps Team 2022-05-11 22:45:14 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-43813

Comment 18 errata-xmlrpc 2022-08-09 20:32:21 UTC
This issue has been addressed in the following products:

  Red Hat Ceph Storage 5.2

Via RHSA-2022:6024 https://access.redhat.com/errata/RHSA-2022:6024


Note You need to log in before you can comment on or make changes to this bug.