Bug 203124 - acroread shell script doesn't work
acroread shell script doesn't work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-18 10:56 EDT by Tom Horsley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-18 12:48:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2006-08-18 10:56:40 EDT
Description of problem:

I installed AdobeReader_enu-7.0.8-1.i386.rpm from adobe's
download site. It installs acroread, which is a #!/bin/sh
script and sh is a symlink to bash. When I try to run
acroread all I get is an infinite number of syntax
errors from "expr" (doesn't happen on FC5, so I figure
something has gone non-compatible with the bash on FC6t2).

Version-Release number of selected component (if applicable):

Not sure, whatever latest update for FC6t2 is (can't check
at the moment).



How reproducible:

Everytime.

Steps to Reproduce:
1. run acroread on any old pdf file
2.
3.
  
Actual results:

expr errors

Expected results:

acrobat reader starts up

Additional info:

I took a look at the acroread shell script, and it has
a function definition called "readlink" which is using
expr inside backticks in a fashion which makes absolutely
no sense to me. I have no idea why acroread works on FC5 :-).
Comment 1 Tim Waugh 2006-08-18 11:08:58 EDT
Could you attach a one- or two-line test case please?
Comment 2 Tom Horsley 2006-08-18 12:22:55 EDT
Maybe it isn't bash, maybe the script has always been busted and the
different version naming of libgtk is confusing it. Trying to figure out
how to reproduce this in a small example, I traced acroread, and it goes
funny in the head after this trace:

++ echo libgtk-x11-2.0.so.0.1000.1
++ sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'
++ return 0
+ version=
+ '[' 0 -ne 0 ']'
++ expr length
expr: syntax error

I note that the libgtk-x11 library on FC6t2 is named:

/usr/lib/libgtk-x11-2.0.so.0.1000.1

whereas on FC5 the name is:

/usr/lib/libgtk-x11-2.0.so.0.800.17

apparently the 4 digits . 1 digit form of the name is too much for
the shell script to digest?
Comment 3 Tim Waugh 2006-08-18 12:48:26 EDT
Indeed.  Closing as NOTABUG since this isn't a bash bug, but rather a bug in
acroread.

Note You need to log in before you can comment on or make changes to this bug.