Bug 2031326 - F34FailsToInstall: usd-libs
Summary: F34FailsToInstall: usd-libs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: usd
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luya Tshimbalanga
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F34FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2021-12-11 01:16 UTC by Miro Hrončok
Modified: 2021-12-20 01:00 UTC (History)
4 users (show)

Fixed In Version: usd-21.08-15.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-12-20 01:00:54 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2021-12-11 01:16:11 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

Your package (usd) Fails To Install in Fedora 34:

can't install usd-libs:
  - nothing provides libopenvdb.so.8.0()(64bit) needed by usd-libs-21.05-3.fc34.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Ben Beasley 2021-12-11 17:54:47 UTC
Hmm. It looks like there are three problems here:

1. OpenVDB’s ABI version changes with each minor release (e.g. 8.0→8.1→8.2)[1] (the soversion is e.g. 8.2, not just 8). Therefore, USD needs to be rebuilt with every minor release update to OpenVDB.

2. ABI version changes or incompatible API changes, even in Rawhide, must be announced a week in advance on the devel list and directly to the maintainers of affected packages[2]. That doesn’t seem to have happened for any recent OpenVDB updates.

3. Incompatible updates conflict with the updates policy for stable releases[3]. In particular, ABI changes are “very strongly discouraged” and really should be brought before FESCo for an exception[4]. That doesn’t seem to have happened either, and recent updates to OpenVDB in F34 and F35[5] shouldn’t have been issued.

[1] https://src.fedoraproject.org/rpms/openvdb/blob/630aef305ed1e33e6b812ddd88139586d093ac82/f/openvdb.spec#_157
[2] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#_rawhide
[3] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#philosophy
[4] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#_exceptions
[5] https://bodhi.fedoraproject.org/updates/?packages=openvdb

-----

This bug can be reproduced in mock only by explicitly trying to install both usd and openvdb-libs. Otherwise, openvdb-libs 8.0.x still gets pulled in.

-----

Since the incompatible OpenVDB update is already in F34 stable, a rebuild of USD is probably the only path forward. I’ll take care of that part.

Comment 2 Ben Beasley 2021-12-11 18:21:51 UTC
USD is 21.05 in F34 stable. It has since been updated to 21.08 in the f34 branch in dist-git, but not built and no updates issued.

Upstream still isn’t doing ABI versioning, so the .so version is set downstream using the major version number, but I’m not 100% confident that the ABI has *actually* stayed the same in the 21.x series.

I will need to take some time to (1) use (fed)abipkgdiff to figure out if the ABI looks OK in 21.08, or (2) revert the update from 21.05 to 21.08, before completing a rebuild.

Comment 3 Ben Beasley 2021-12-11 18:29:01 UTC
> fedabipkgdiff --from fc34 x/*
> Comparing the ABI of binaries between usd-libs-21.05-3.fc34.x86_64.rpm and usd-libs-21.08-15.fc34.x86_64.rpm:
> 

That’s encouraging. I think a rebuild will be sufficient.

Comment 4 Luya Tshimbalanga 2021-12-11 19:59:23 UTC
One problem. Imath is not available on F34 repository so attempting to disable it.

Comment 5 Ben Beasley 2021-12-11 20:02:48 UTC
(In reply to Luya Tshimbalanga from comment #4)
> One problem. Imath is not available on F34 repository so attempting to
> disable it.

Agreed. I have a commit that fixes this but haven’t pushed it yet.

Comment 6 Luya Tshimbalanga 2021-12-11 20:21:31 UTC
(In reply to Ben Beasley from comment #5)
> (In reply to Luya Tshimbalanga from comment #4)
> > One problem. Imath is not available on F34 repository so attempting to
> > disable it.
> 
> Agreed. I have a commit that fixes this but haven’t pushed it yet.

You can proceed.

Comment 7 Ben Beasley 2021-12-11 20:32:43 UTC
> You can proceed.

Thanks. Just got back to a computer. I have pushed the commit and am rebuilding now: https://koji.fedoraproject.org/koji/taskinfo?taskID=79849309

Comment 8 Fedora Update System 2021-12-11 22:02:46 UTC
FEDORA-2021-08a0ca1611 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-08a0ca1611

Comment 9 Fedora Update System 2021-12-12 01:57:23 UTC
FEDORA-2021-08a0ca1611 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-08a0ca1611`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-08a0ca1611

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Colin Barker 2021-12-14 12:20:22 UTC
FC34:: usd-libs-21 dependency on libopenvdb.so.8.0 - no provider can be installed.

# dnf update
Last metadata expiration check: 1:32:25 ago on Tue 14 Dec 2021 10:30:35 GMT.
Dependencies resolved.

 Problem 1: package usd-libs-21.05-3.fc34.x86_64 requires libopenvdb.so.8.0()(64bit), but none of the providers can be installed
  - cannot install both openvdb-libs-8.2.0-1.fc34.x86_64 and openvdb-libs-8.0.1-2.fc34.x86_64
  - cannot install the best update candidate for package usd-libs-21.05-3.fc34.x86_64
  - cannot install the best update candidate for package openvdb-libs-8.0.1-2.fc34.x86_64
 Problem 2: problem with installed package usd-libs-21.05-3.fc34.x86_64
  - package usd-libs-21.05-3.fc34.x86_64 requires libopenvdb.so.8.0()(64bit), but none of the providers can be installed
  - cannot install both openvdb-libs-8.2.0-1.fc34.x86_64 and openvdb-libs-8.0.1-2.fc34.x86_64
  - package OpenImageIO-2.2.19.0-2.fc34.x86_64 requires libopenvdb.so.8.2()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package OpenImageIO-2.2.19.0-1.fc34.x86_64
================================================================================================================================================================================================================================================
 Package                                                     Architecture                                          Version                                                         Repository                                              Size
================================================================================================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 openvdb-libs                                                x86_64                                                8.2.0-1.fc34                                                    updates                                                967 k
Skipping packages with broken dependencies:
 OpenImageIO                                                 x86_64                                                2.2.19.0-2.fc34                                                 updates                                                2.4 M

Transaction Summary
================================================================================================================================================================================================================================================
Skip  2 Packages

Nothing to do.
Complete!

Comment 11 Ben Beasley 2021-12-14 15:05:25 UTC
(In reply to Colin Barker from comment #10)
> FC34:: usd-libs-21 dependency on libopenvdb.so.8.0 - no provider can be
> installed.

The rebuilt package that should fix this is still in updates-testing. Please see comment #9 above for instructions on testing that. It should resolve this issue for you, but I would like to hear about any problems you do encounter.

You can expect the update to reach stable Fedora 34 repositories in about five days. At that point, a plain “dnf update” will install it.

Comment 12 Fedora Update System 2021-12-20 01:00:54 UTC
FEDORA-2021-08a0ca1611 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.