Bug 203171 - Fedora Core 5 can no longer act as a scan server
Fedora Core 5 can no longer act as a scan server
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-18 14:48 EDT by Jean Francois Martinez
Modified: 2008-01-30 10:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 10:56:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jean Francois Martinez 2006-08-18 14:48:57 EDT
Description of problem:
Permissions for scanner are set incorrectly.  Consequence is that machine
no longer can act as a scan server

Version-Release number of selected component (if applicable):
sane-backends-1.0.17-5.fc5.9

How reproducible:
Always

Steps to Reproduce:
1.  Plug an USB scanner 
2.  Check permissions you will get owner=myuser 
3.
  
Actual results:
owner=myuser (the one who is logged in at the console) group=root perm=600

Expected results:
owner=myuser (so console user can scan) group=sane perm=660 ( when started by
xinetd I run sane with group sane, the xinetd file is my own since Fedora
doesn't provide one, this could count as an additional bug)  

Additional info:


Fedora Core 4 ran fine as a scanner server.  Short term solution is fix
permissions manually but as soon as console user unlogs these are reset.  :-(

It appears that the udev rules in the sane package don't care for permissions
and these are set by the 
/etc/udev/rules.d/95-pam-console.rules

I am running with Selinux disabled.
Comment 1 Jean Francois Martinez 2006-08-19 03:25:02 EDT
In fact the problem is in the  /etc/security/console.perms.d/50-default.perms
file (belonging to pam).  In Fedora 4 the incorrect permissions set by this 
file were overridden by the permissions set by hotplug so, at least when 
scanner was powered on after login (I think I never had my scanner powered on 
before loggin in), the bug was hidden.  But Fedora 5 uses udev instead and 
this invokes
pam_console_apply to set permissions like required by pam.

Bug should be reassigned to the pam maintainer.
Comment 2 Tomas Mraz 2006-08-25 09:28:16 EDT
The problem is group sane cannot be used in 50-default.perms in the rpm as
revert group, because the group is not in the default /etc/group. You can edit
the file yourself or add another .perms file with higher number to override the
50-default.perms default.
Comment 3 Tomas Mraz 2008-01-30 10:56:39 EST
ConsoleKit is the way to go now.

Note You need to log in before you can comment on or make changes to this bug.