Bug 2031940 - Please branch and build python-rpmautospec in epel9
Summary: Please branch and build python-rpmautospec in epel9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-rpmautospec
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2046036 (view as bug list)
Depends On: 2039305
Blocks: EPELPackagersSIG 2046034
TreeView+ depends on / blocked
 
Reported: 2021-12-13 18:30 UTC by Miro Hrončok
Modified: 2022-05-17 03:04 UTC (History)
11 users (show)

Fixed In Version: python-rpmautospec-0.2.6-2.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-17 03:04:21 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2021-12-13 18:30:42 UTC
Please branch and build python-rpmautospec in epel9.

If you do not wish to maintain python-rpmautospec in epel9,
or do not think you will be able to do this in a timely manner,
I would be happy to be a co-maintainer of the package.

Comment 1 Miro Hrončok 2022-01-11 13:52:35 UTC
Please?

Comment 2 Miro Hrončok 2022-01-31 09:33:18 UTC
I'd rather not maintain this in EPEL 9 myself, so asking again. Could you please do that?

Comment 3 Kevin Fenzi 2022-02-05 20:07:35 UTC
Perhaps Nils would have time to work on this? If it's just branch and build I could do it, but it would be good to do a bit more testing...

Comment 4 Ben Cotton 2022-02-08 20:14:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 36 development cycle.
Changing version to 36.

Comment 5 Miro Hrončok 2022-02-18 10:20:20 UTC
Nils, Adam, anybody?

Comment 6 Michel Lind 2022-02-25 12:43:47 UTC
It's been awhile with no update, so let's have EPEL Packagers SIG co maintain this. I'll file a stalled request releng ticket

Per EPEL policy, we can always drop this later if it's too tedious to maintain

Comment 7 Michel Lind 2022-02-25 17:40:32 UTC
Stalled request filed: https://pagure.io/releng/issue/10672

Comment 8 Michel Lind 2022-02-28 20:37:45 UTC
$ fedpkg request-branch --repo python-rpmautospec epel9
https://pagure.io/releng/fedora-scm-requests/issue/42608

Comment 9 Troy Dawson 2022-04-13 16:23:56 UTC
*** Bug 2046036 has been marked as a duplicate of this bug. ***

Comment 10 Troy Dawson 2022-04-13 16:29:16 UTC
Just so people know this has been branched for epel9.
But the build currently fails on tests/%check

Comment 16 Nils Philippsen 2022-05-15 11:40:32 UTC
Sorry for missing this for so long. I'll look into this.

Comment 17 Fedora Update System 2022-05-15 11:52:33 UTC
FEDORA-EPEL-2022-3c4efd0b6a has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-3c4efd0b6a

Comment 18 Nils Philippsen 2022-05-15 11:55:33 UTC
This was just a matter of that building the package attempts to run the unit tests in parallel using python-pytest-xdist which so far isn't available in EL9 (see https://bugzilla.redhat.com/show_bug.cgi?id=2032588). I've patched the spec file and submitted an update.

Comment 19 Fedora Update System 2022-05-16 02:31:45 UTC
FEDORA-EPEL-2022-3c4efd0b6a has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-3c4efd0b6a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2022-05-17 03:04:21 UTC
FEDORA-EPEL-2022-3c4efd0b6a has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.