Bug 203230 - Anaconda leaves stuff in /tmp after Kadischi run
Anaconda leaves stuff in /tmp after Kadischi run
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2006-08-19 12:51 EDT by Jasper O. Hartline
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 20:44:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jasper O. Hartline 2006-08-19 12:51:55 EDT
Description of problem:
While runnnning Anaconda under Kadischi, Anaconda leaves stuff leftover in /tmp.
While Kadischi could clean this up, I think it might be better if Anaconda does
instead.

Known items left in /tmp after runnnign Anaconda under Kadischi are:
/tmp/cache
/tmp/product
/tmp/updates
device files, like hda, hdb, hdc etc.

Version-Release number of selected component (if applicable):
anaconda-11.1.0.83-1

How reproducible:
Run Anaconda under Kadischi.

Steps to Reproduce:
1. kadischi --text /path/to/repo -f /tmp/fc.iso
2.
3.
  
Actual results:
Leftover items in /tmp

Expected results:
Anaconda shouldn't leave anything in /tmp

Additional info:
There is no additional information at this time.
Comment 1 Jeremy Katz 2006-08-22 19:57:20 EDT
Yep, there are still assumptions throughout anaconda about it running in the
magic installer environment where things don't persist.

We'll take fixes for explicit cases, but not going to make any sort of real push
on cleaning this up for FC6 at this point.
Comment 2 David Cantrell 2007-03-15 14:58:07 EDT
Anaconda puts stuff in /tmp because it's a ramfs that disappears after reboot. 
If you want to modify anaconda to clean up before exit, we will accept and
review patches.
Comment 3 Bug Zapper 2008-04-03 13:59:07 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Note You need to log in before you can comment on or make changes to this bug.