Bug 203242 - PATCH: fix /sbin/mkinitrd --without-usb option
PATCH: fix /sbin/mkinitrd --without-usb option
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-19 14:34 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 11:47:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH: fixing --without-usb (298 bytes, patch)
2006-08-19 14:34 EDT, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2006-08-19 14:34:38 EDT
/sbin/mkinitrd contains a variable "withusb" which contains either "1" or "0",
however this variable is tested like this:
if [ -n "$withusb" ]; then

Which is always true because "withusb" always is a non zero lenght string, the
correct test would be:
if [ $withusb -ne 0 ]; then

The attached patch fixes this.
Comment 1 Hans de Goede 2006-08-19 14:34:40 EDT
Created attachment 134513 [details]
PATCH: fixing --without-usb
Comment 2 Peter Jones 2006-09-14 11:47:59 EDT
Applied in CVS, thanks.

Note You need to log in before you can comment on or make changes to this bug.