Bug 203243 - "peth0 received packet on own address" seen in normal config of Xen
Summary: "peth0 received packet on own address" seen in normal config of Xen
Status: CLOSED DUPLICATE of bug 200360
Alias: None
Product: Fedora
Classification: Fedora
Component: xen   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Herbert Xu
QA Contact: Brian Brock
URL: http://lists.xensource.com/archives/h...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-19 18:42 UTC by Russell McOrmond
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 16:13:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Russell McOrmond 2006-08-19 18:42:57 UTC
Description of problem:

If you run more than one Xen on the same LAN there is a conflict between the use
of a static HW address for peth0 and the ICMPv6 Neighbor
Solicitation that happens for IPv6.

You can read a description of the problem at
http://lists.xensource.com/archives/html/xen-devel/2006-04/msg01305.html

  I believe the solution would be to have the default Xen scripts that set up
peth0 and the various vif?.0 interfaces to configure them without IPv6 enabled
on those interfaces.  I don't want to globally turn off IPv6 for other
interfaces, just for those set up by Xen that would otherwise be duplicates.

Bug also discussed in http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=339
It would be great if the "External Bugzilla" part of this form would also be
able to link to Xensource.

Comment 1 Michael Richardson 2006-09-16 13:03:00 UTC
if we can't prevent the IPv6 link-local address from being auto-configured,
then we need to make sure that the MAC given to peth0 is unique. My suggestion
is that the 10:00:00 OUI is a "local use" OUI, and that we set the MAC to:

10:00:00:XX:YY:ZZ, where XX,YY,ZZ are the local three octets of the IPv4. That
ought to be unique on the local LAN, assuming that there are no duplicate IPv4,
and assuming that there aren't multiple /8's with overlapping addresses.


Comment 2 Russell McOrmond 2006-09-16 19:42:02 UTC
While not a long-term solution (I like Mike Richardson's suggestion), I wanted
to post a note about what I did to get rid of the messages on my own LAN.

In /etc/rc.d/rc.local  I have added the following lines:

ip addr del fe80::fcff:ffff:feff:ffff/64 dev peth0
ip addr del fe80::200:ff:fe00:0/64 dev xenbr0

Comment 3 Daniel Berrange 2006-09-18 14:06:20 UTC
> It would be great if the "External Bugzilla" part of this form would also be
> able to link to Xensource.

FYI, the XenSource bugzilla is now available in the drop-down.


Comment 4 Herbert Xu 2006-09-18 16:13:19 UTC

*** This bug has been marked as a duplicate of 200360 ***


Note You need to log in before you can comment on or make changes to this bug.