Bug 20325 - syntax error in /usr/lib/rpm/find-provides
Summary: syntax error in /usr/lib/rpm/find-provides
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-04 00:49 UTC by greg hosler
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-04 00:50:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description greg hosler 2000-11-04 00:49:59 UTC
When I do a rpm -bb, at the end when it is finding the dependencies, I see
the
following message scrolled to the screen:

Processing files: <rpm name>
Finding  Provides: (using 
line 186: Dependency tokens must begin with alpha-numeric, '_' or '/': 

Failed to find Provides:

=============

I looked at line 186 of /usr/lib/rpm/find-provides, and see

	done | sort -u

might it be the case that the whole

	for ... do | sort -u

needs to be

	(for ... do) | sort -u

?

Comment 1 Jeff Johnson 2000-12-17 01:30:38 UTC
No, the find-provides script is returning something unusual in your build,
almost certainly
because of what is in your build.

Try doing
	rpm -i <your_src_rpm>
	rpm -bi /usr/src/redhat/SPECS/<your_spec_file>
and then doing
	find <your_build_root> | /usr/lib/rpm/find-provides
to examine what find-requires is returning from the installed tree (i.e. what's
in $RPM_BUILD_ROOT).


Note You need to log in before you can comment on or make changes to this bug.