This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 203259 - nano long line segfault
nano long line segfault
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nano (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: David Woodhouse
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-19 19:19 EDT by Trevor Cordes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 12:27:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Trevor Cordes 2006-08-19 19:19:59 EDT
Description of problem:
The current FC5 version of nano contains a long-line segfault bug that has been
fixed by the developers.  Please push latest nano version into updates.  Bug
triggers on me every day editing text files with long lines.  Crash causes loss
of data since last save.


Version-Release number of selected component (if applicable):
nano-1.3.8-1.2.1


How reproducible:
Every day, but can't pinpoint exactly what triggers it as file is long and
complicated.  Already fixed by developers.


Steps to Reproduce:
1. edit a file with very long (>500 char) lines
2.
3.
  
Actual results:
segfaults

Expected results:
no segfault -- never caused a problem in the FC3 nano on same file

Additional info:
version that fixes bug 1.3.11
http://lists.gnu.org/archive/html/info-nano/2006-03/msg00002.html
Comment 1 Florian La Roche 2007-02-05 12:27:30 EST
Newer version is in FC-development, so I am closing this bug report.

regards,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.