Bug 203279 - KDE 3.5.4 has problems rendering fonts in FC5
KDE 3.5.4 has problems rendering fonts in FC5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-20 10:37 EDT by Mike Cohler
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: kdebase-3.5.4-0.4.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 04:09:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of font problems in yumex (388.36 KB, image/png)
2006-08-23 13:27 EDT, Brian Daniels
no flags Details
kdebase-3.5.4-antialias.patch from kdebase-3.5.4-3ark.src.rpm (429 bytes, patch)
2006-08-23 15:19 EDT, Jon Burgess
no flags Details | Diff

  None (edit)
Description Mike Cohler 2006-08-20 10:37:55 EDT
Description of problem:After upgrade to KDE 3.5.4 fonts as rendered using Sans
for all except Fixed Width and Window title (in control centre under fonts) are
unattractive and make the eyes strain. Even altering the sub-pixel hinting
settings do not help with some displays on some computers this was checked on.


Version-Release number of selected component (if applicable):kdebase-3.5.4-0.2.fc5


How reproducible:Every time on a specific computer


Steps to Reproduce:
1. Upgrade to kdebase-3.5.4-0.2.fc5 
2. See awful font rendering.
3.
  
Actual results: Fonts are a strain on the eye and terrible to look at.


Expected results: Fonts should be as they were in KDE 3.5.3


Additional info:
Comment 1 Brian Daniels 2006-08-20 21:56:26 EDT
Something strange is going on.  I had the same problem as the above on my AMD64
install of FC5 - but then it self-corrected!  Sequence:

1. yum update installed kde and kernel updates, among others.
2. Rebooted to new kernel.
3. KDE looks terrible, all fonts wrong as above.
4. Opened Control Center, right font names but they look awful.
5. Launch firefox, bad fonts there too.
6. /etc/init.d/xfs status to verify xfs running, it is.
7. Opened an xterm to see if it's affected.  xterm has it's normal (ugly) font.
8. Opened Control center again to mess with font settings, fonts are back to normal!

Rebooted to check, and everything stays fine.  I don't know if this was a time
based issue, or something to do with launching 'xterm'?  But my system is fine
now.  Weird...
Comment 2 Torsten Rohlfing 2006-08-20 23:25:23 EDT
On my AMD64, I had to do "/etc/init.d/xfs restart", then fonts for new windows
were back to normal. So no self correction here, but a manual fix.
Comment 3 Ngo Than 2006-08-22 07:31:51 EDT
I cannot reprpoduce this problem here, it works for me with KDE-3.5.4.
It could be that new xorg-x11-xfs-1.0.1-4.FC5 has caused this problem
Comment 4 Mike Cohler 2006-08-22 08:21:39 EDT
It seems to depend on the hardware - I have the problem on only a few of the 8
machines I have tested - all with the same setup. 

Mike
Comment 5 Mike Cohler 2006-08-22 12:26:31 EDT
I switched the main fonts from Sans to Bitstream Vera Sans in the Control Centre
- which is slightly easier on the eye but not perfect.  I do hope that this will
not be a problem with the release version of FC6 when it comes out.

I wonder what font settings others are using for KDE ?
Comment 6 Richard Allen 2006-08-22 12:31:12 EDT
I'm having the same problem...  I tried logging in as various users is KDE, bad
fonts every time.   I even created a new user to test this thing and no luck.
Gnome however works :(

restarting xfs has no effect here, except for a very strange thing that happens
every time.
I have a shortcut on my desktop that simply launches an xterm with "xterm -ls"
and I do a "sodu su -" and the "service xfs restart" and every time the xterm
closes or hangs :)   I'm using the is_IS.UTF-8 locale if that matters.
Comment 7 Richard Allen 2006-08-22 13:20:56 EDT
I've done some digging and a colleague of mine has a very similar setup but his
fonts are fine.    I'm looking at xfs as a possible cause for the problem and
I've seen a difference in how xfs behaves on our two machines.

xfs       2800     1  0 17:11 ?        00:00:00 xfs -daemon -droppriv

[root@morticia ~]# lsof -p 2800 | tail -5
xfs     2800  xfs    0u   CHR        1,3             1003 /dev/null
xfs     2800  xfs    1u   CHR        1,3             1003 /dev/null
xfs     2800  xfs    2u   CHR        1,3             1003 /dev/null
xfs     2800  xfs    3u  unix 0xe7503080             8336 /tmp/.font-unix/fs7100
xfs     2800  xfs    4u  unix 0xea293800             8338 /tmp/.font-unix/fs7100

My xfs (where KDE fonts are broken) has the socket open twice.
His xfs (where KDE fonts are OK) only has it open once.

Both xfs's have:

xfs     2800  xfs  mem    REG        3,6   46608 11305000 /lib/libnss_files-2.4.so
xfs     2800  xfs  mem    REG        0,0                0 [vdso] (stat: No such
file or directory)
xfs     2800  xfs  mem    REG        3,6  121396 11304962 /lib/ld-2.4.so

I dont have any idea if this matters :)
Comment 8 Mike Cohler 2006-08-23 04:21:29 EDT
As a test I resorted to installing ms truetype fonts and chose Tahoma 10 as the
main KDE font set with antialiasing and sub-pixel hinting - and this is a lot
better on the eyes!   Possibly the freetype fonts with BCI and fiddling with
that aspect may help but I have not tried that.
Comment 9 Brian Daniels 2006-08-23 13:27:14 EDT
Created attachment 134732 [details]
Screenshot of font problems in yumex
Comment 10 Brian Daniels 2006-08-23 13:28:23 EDT
Another oddity - although I reported the problem as self-resolving above, yumex
is still showing up with a bad font.  My other applications (konsole, firefox,
thunderbird, konqueror) are all looking ok.  Screenshot above.
Comment 11 Jon Burgess 2006-08-23 14:43:45 EDT
I saw this on 2 systems. I think I fixed it on one by kcontrol -> Appearance ->
fonts -> use Anti-aliasing for fonts.
This resulted in the following keys in ~/.kde/share/config/kdeglobals:
...
[General]
UseSystemBell=true
XftAntialias=true
XftSubPixel=none
...

The equivalent file on the broken system is missing these keys.
Perhaps the default behaviour when the key is missing has changed?
Comment 12 Brian Daniels 2006-08-23 14:53:22 EDT
That fixed yumex on my system.  My fonts settings in kcontrol already had use
Anti-aliasing turned on, but the Xft entries were missing from kdeglobals. 
Turned anti-aliasing off, applied, turned it back on.  Now the entries are
there, and yumex looks fine.

Comment 13 Jon Burgess 2006-08-23 15:09:37 EDT
Yes, Google turned up several other reports of similar problems with 3.5.4 on
Debian & Suse. Disabling and re-enabling the anti-aliasing setting in kcontrol
seems to be the recommended "fix". 

There are suggestions that it is due to a change in the interaction between the
various font settings in ~/.qt/qtrc, ~/.fonts.conf, .Xresources &
~/.kde/share/config/kdeglobals
Comment 14 Jon Burgess 2006-08-23 15:19:38 EDT
Created attachment 134743 [details]
kdebase-3.5.4-antialias.patch from kdebase-3.5.4-3ark.src.rpm

The attached patch is from Arklinux kdebase-3.5.4-3ark.src.rpm and I think it
fixes the behaviour by making the default setting enabled if the key is
missing. I've not tried it, but it looks promising to me.
Comment 15 Mike Cohler 2006-08-24 03:26:17 EDT
It looks like this bug may have been set  to status closed a bit prematurely.
I am going to re-open it - I hope that this is in order.
Comment 16 Mike Cohler 2006-08-24 03:31:15 EDT
It is possible that the problems are not directly the responsibility of the KDE
maintainer but possibly due to something not right in xorg or another part of
the system?  But since it seems that various different systems are indeed
experiencing these problems it would be valuable to find what the source of the
problem is. xorg-X11-fonts, fonts-xorg, fontconfig ?   Maybe someone seeing this
bugzilla knows what the best way to pin this down might be.
Comment 17 Mike Cohler 2006-08-24 03:53:08 EDT
I have just seen a posting in Fedora List by LPM:
"Open KDE Control Center => Appearance and Themes => Fonts

uncheck "use anti-aliasing for fonts", click apply, then recheck it and
apply.  Log out and back into your desktop.  This is needed due to
changes in the font rendering in KDE 3.5.4."

I tried this after changing the font settings back to the original I had in one
machine which had a problem and now the font rendering is OK again !

If others try this and find the problem goes away then this bug can be closed
again.  I will check this this on other machines later today.

Note You need to log in before you can comment on or make changes to this bug.