Bug 203284 - no windowmanager decorations
Summary: no windowmanager decorations
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-20 16:41 UTC by Andy Burns
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 19:33:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andy Burns 2006-08-20 16:41:37 UTC
Description of problem:
I have Fc6T2  with latest mesa/xorg updates, compiz is running and I have spinny
desktop cubes, I can see vestigial wibbly windows effects on tooltips and combo
boxes, but I have no decorations on any windows, i.e no borders, titlebar,
min/max/restore widgets, and windows don't respond to ALT-F7/F8 type keyboard
shortcuts  

Version-Release number of selected component (if applicable):
Version: 0.0.13
Release: 0.16.20060817git.fc6

How reproducible:
100%

Steps to Reproduce:
1. enable desktop effects + wobbly + desktop cube
2. login and open apps

  
Actual results:
apps start, but with no apparent windowmanager functions, compiz process is
however present,

Expected results:
window manager functions availabke

Additional info:
radeon X550 using xorg 7.1 drivver *not* fglrx

Comment 1 Andy Burns 2006-08-20 18:59:43 UTC
Fully updated to latest rawhide, specifically

Name   : compiz
Arch   : x86_64
Version: 0.0.13
Release: 0.16.20060817git.fc6

and still not getting borders etc, it seems if I disable then re-enable desktop
effects, I do get menu bars on apps, but still no borders, and the menus then
disappear on next X restart.


Comment 2 Kristian Høgsberg 2006-08-23 15:34:44 UTC
This could be a problem where the earlier versions the compiz rpm would corrupt
its gconf settings on upgrade.  Try rpm -e compiz, gconftool-2 --recursive-unset
/apps/compiz (as your normal user) and then reinstall.  Thanks.

Comment 3 Kristian Høgsberg 2006-10-02 19:33:43 UTC
Closing due to lack of response, and because it's very like the gconf problem
mentioned in comment #2.


Note You need to log in before you can comment on or make changes to this bug.