Bug 203306 - fc4, fc5, fc6, fc7 won't confgure pcmcia modem
fc4, fc5, fc6, fc7 won't confgure pcmcia modem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
not applicable
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-20 21:20 EDT by John F. Kohler
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 04:02:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John F. Kohler 2006-08-20 21:20:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
When I try to configure a modem, the system does not detect the pcmcia 
usr 56k modem at the com port tty/S3 as was done with fc3. In fact, no
dialog box comes up showing a found modem at all.  The laptop, a Dell inspiron 4150 has a winmodem built in and my pcmcia card.  

Version-Release number of selected component (if applicable):
kernel 2.6.11-1.1369_fc48i686

How reproducible:
Always

Steps to Reproduce:
1.Click on red hat and drag down to system settings->network
2.click on network wizard, and in dialog box, choose "new"
3.click on modem. (note no attempt to locate modem port tty/S3 as was done on fc3)
4. see dialog box for isp, phone number, and password
5 enter info and click done.
  

Actual Results:  When you click "activate" error message comes up ppp0 connection failed, errot 2

Expected Results:  A good modem connection should have been established, dialing, answer, and connection with id/password pair and ready for activation of browser

Additional info:

This was an issue for me on the same laptop under Red Hat Linux 9, but I do not know if the cause is the same.  I have returned to fc3 and the modem, software and connection work perfectly.

P.S. under fc4 I attempted to activate "minicom -s" and successfully dialed out with it.
Comment 1 John F. Kohler 2006-08-20 21:24:59 EDT
At LinuxWorld Expo in SF, a Fedora Systems Engineer suggested that the kernel
does not make a link to the existing modem driver.

He gave me the following command line suggestion:

/sbin/modprobe i82092

And an additional line to be placed in the file system to be added with a text
editor (which I'll have to learn)

/etc/rc.d/rc/local


This fix worked on Fedora 5, so presumably it would work on FC 4 as well

John
Comment 2 Christian Iseli 2007-01-19 19:25:59 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 3 John F. Kohler 2007-01-19 23:26:29 EST
Yes, I am travelling now, using FC3 which is pcmcia modem compatible.

When I get home, I'll try both FC$ and FC5 for compatibility to a 56k pcmcia 
modem.

John
Comment 4 John F. Kohler 2007-01-28 02:25:31 EST
I tried FC 4 and FC 5 now the EOL's have been restored.

I installed each from its original DVD, and made a "yum update" from each.

Neither one would recognize the pcmcia 56k modem in my ttyS3 port.

Returning to FC 3, everything worked, including the KUDZU dialog box during the
installation process, asking to keep configuration for a generic modem.

I have purchased the Christopher Negus "Bible" for Fedora 6 with an installation
DVD included.

I am betting FC 6 won't recognize the modem either.

John
Comment 5 John F. Kohler 2007-01-29 10:40:44 EST
Fedora Core 6 behaves exactly the same way, The path is different under FC-6.
System-->Administration-->network

On the Network Configuration dialog box, click on "new"
Select "Modem Connection" and wait for Modem Probing to complete.
A dialog box appears for system-config-network:  "no modem was found on your
system." 

Again, I have a pcmcia 56k modem which will be detected by kudzu on Fedora Core
3 as a generic modem at the ttyS3 serial port...
Comment 6 John F. Kohler 2007-05-19 23:23:33 EDT
It is May 19, 2007.

Nothing changed in Fedora 4, 5, or 6.
Fedora 3 still works: finds modem on installation with kudzu, and configures to
ttyS3 once installed.

Additional information:  Ubuntu 6.10 fails to configure a PCMCIA modem in the
exact manner.  Could it be all linux kernels after a certain date??? 

I am thinking of a table top modem to plug into the regular serial port on the
laptop and see if it is recognized/configured....
Comment 7 John F. Kohler 2007-06-25 16:30:13 EDT
I have just learned that there was an "old" PCMCIA driver (PCMCIA-CS) which was
in cluded in the kernel version of Fedora 3 and a "new"  PCMCIA driver
(PCMCIA-utils) which has been used in later versions of Fedora and the one
version of Ubuntu which I tried (Ubuntu 6.10)

I am wondering whether or not the PCMCIA driver does or does not recognize a 56k
modem in the PCMCIA slot?

John
Comment 8 John F. Kohler 2007-08-07 21:15:00 EDT
I just obtained Fedora 7 at the local LinuxWorld Expo in 2 forms.  The Install
disk failed to perform the "first boot" and I discarded it.  The "Live" disk
installed successfully, but could not locate the PCMCIA 56k analog modem in the
laptop.  Updates were performed, including a pcmcia-utils and kudzu, which may
correct the issue.

John
Comment 9 John F. Kohler 2007-08-07 21:41:03 EDT
Following the online update of Fedora Core 7, I once again attempted the graphic
"network configuration" from the desktop menu.  from administration to network
to configuration to "add modem" all was the same. Upon clicking "new" in that
screen the system searched for and found my pcmcia modem.  I configured the ISP
phone number, id and password, connected a phone line and got a successful
dialup connection at 28kbps.

It works now.

Note You need to log in before you can comment on or make changes to this bug.