Bug 20331 - procinfo shows wrong number of CPUs
Summary: procinfo shows wrong number of CPUs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procinfo   
(Show other bugs)
Version: 6.2
Hardware: sparc Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-04 13:14 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-04 13:15:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-11-04 13:14:58 UTC
On a single CPU SparcClassic procinfo shows number of CPUs to be 3.
Because of that overall percentage of system/user/... cput time is
also wrong.
$ cat /proc/cpuinfo 
cpu             : Texas Instruments, Inc. - MicroSparc
fpu             : TI MicroSparc on chip FPU
promlib         : Version 3 Revision 2
prom            : 2.20
type            : sun4m
ncpus probed    : 1
ncpus active    : 1
BogoMips        : 49.76
MMU type        : TI Tsunami
contexts        : 64
nocache total   : 1048576
nocache used    : 251136

$ procinfo
Linux 2.4.0-test10 (green@morgoth) (gcc 2.95.2 19991024 ) #2 3CPU [dredd]

Memory:      Total        Used        Free      Shared     Buffers     
Cached
Mem:         44988       43940        1048           0        2960      
12972
Swap:        51320           0       51320

Bootup: Wed Nov  1 12:02:41 2000    Load average: 0.00 0.04 0.00 1/45 2524

user  :       1:28:32.77   0.6%  page in :    40534
nice  :       0:00:00.00   0.0%  page out:    28295
system:       0:34:29.78   0.2%  swap in :        1
idle  :   3d  2:09:43.67  32.4%  swap out:        0
uptime:   3d  4:12:46.21         context :  6710348

irq  4:    221331 ESP SCSI              irq 11:         2
floppy               
irq  6:   1426927 LANCE                 irq 12:      1233
Zilog8530            
irq 10:  27436623 timer

Comment 1 Bernhard Rosenkraenzer 2000-11-04 13:59:35 UTC
This is fixed in the current version.


Note You need to log in before you can comment on or make changes to this bug.