Bug 2033112 - Please branch and build python-pathspec in epel9
Summary: Please branch and build python-pathspec in epel9
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-pathspec
Version: epel9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adrien Vergé
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2041978 (view as bug list)
Depends On:
Blocks: 2042006
TreeView+ depends on / blocked
 
Reported: 2021-12-15 23:56 UTC by Robby Callicotte
Modified: 2022-02-01 01:23 UTC (History)
4 users (show)

Fixed In Version: python-pathspec-0.9.0-1.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-01 01:23:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Robby Callicotte 2021-12-15 23:56:48 UTC
Description of problem:


Please branch and build python-pathspec for epel9.

Koji scratch build:
https://koji.fedoraproject.org/koji/taskinfo?taskID=80055371


I can help co-maintain this package.

Comment 1 Miro Hrončok 2021-12-16 09:36:50 UTC
As a co-maintainer, I don't mind if you do, but I am not doing it.

Comment 2 Adrien Vergé 2021-12-16 14:47:11 UTC
Hello, I just requested a new branch: https://pagure.io/releng/fedora-scm-requests/issue/39768

Comment 3 Robby Callicotte 2021-12-31 19:36:54 UTC
Opened a PR: https://src.fedoraproject.org/rpms/python-pathspec/pull-request/7

Comment 4 Miro Hrončok 2022-01-18 16:33:04 UTC
*** Bug 2041978 has been marked as a duplicate of this bug. ***

Comment 5 Miro Hrončok 2022-01-18 16:34:04 UTC
This is now finally fixed in distgit. Whoever requested the branch, now is your time to build it and ship it.

Comment 6 Robby Callicotte 2022-01-18 19:08:21 UTC
@dradez has submitted a koji build (https://koji.fedoraproject.org/koji/taskinfo?taskID=81416018).  I attempted to create an update via bodhi, but I do not have commit access to the repo.

Comment 7 Dan Radez 2022-01-18 22:03:50 UTC
I don't think I have access either. Maybe we could get Adrien to do it. I see Miro and Adrien are the maintainers so they should have permission.

Comment 8 Miro Hrončok 2022-01-18 22:53:44 UTC
I have permission but no intention to maintain an API-stable version of pathspec for a decade. I can help this one time, but I'd rather avoid doing it not to be "the person who brought this in".

Comment 9 Dan Radez 2022-01-18 23:16:48 UTC
Miro, If you'd be willing for me to be a co-maintainer I can service the epel9 branch and builds for the package.

Comment 10 Miro Hrončok 2022-01-18 23:44:14 UTC
Done.

Comment 11 Robby Callicotte 2022-01-19 02:00:24 UTC
I am also interested in co-maintaining this package.

Comment 12 Fedora Update System 2022-01-19 03:09:14 UTC
FEDORA-EPEL-2022-b1ed1bcdeb has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-b1ed1bcdeb

Comment 13 Adrien Vergé 2022-01-19 07:40:31 UTC
Thanks Miro, Robby and Dan for your work here. Last month when I created the epel9 branch and updated the spec file to latest version, builds on Koji were failing. I'm glad that it works now.

Comment 14 Fedora Update System 2022-01-23 07:47:36 UTC
FEDORA-EPEL-2022-b1ed1bcdeb has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-b1ed1bcdeb

Comment 15 Fedora Update System 2022-01-24 01:26:32 UTC
FEDORA-EPEL-2022-b1ed1bcdeb has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-b1ed1bcdeb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2022-02-01 01:23:12 UTC
FEDORA-EPEL-2022-b1ed1bcdeb has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.