Bug 203317 - Copying/moving files across partitions broken
Copying/moving files across partitions broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: Reopened
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-08-20 23:17 EDT by Deji Akingunola
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-30 10:59:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Deji Akingunola 2006-08-20 23:17:44 EDT
Description of problem: I've noticed that current nautilus have issues moving or
copying a relatively large file (>10.MB) over different partitions. It actually
starts the move (or the copying), then ETA begins to grow almost geometrically.
Perfoming the same operation on the terminal doesn't have this problem, files
get transfered asap (depending on the size). For example, while trying to copy a
35MB file, nautilus start showing the progress bar at ~1/4 of the way, then
seems to get stuck as the ETA grows; copying from the terminal takes ~2 secs.


Version-Release number of selected component (if applicable):nautilus-2.15.91-2.fc6


How reproducible: Always


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: This happens with transfers between different partitions on the
same disk, and also between an external usb disk and the system partition. If it
matters, this is on a x86_64 installation.
Comment 1 Alexander Larsson 2006-08-21 08:31:44 EDT
I see this on i386 too.
Comment 2 Alexander Larsson 2006-08-21 10:55:46 EDT
I have a workaround in gnome-vfs upstream cvs, will be in the next release.(2.15.92)
Comment 3 Deji Akingunola 2006-08-21 11:10:17 EDT
Thanks, I'll be on look-out for it.
Comment 4 Alexander Larsson 2006-08-21 13:03:46 EDT
Should be fixed in gnome-vfs 2.15.92-1
Comment 5 Deji Akingunola 2006-08-29 03:20:34 EDT
This (or rather similar) is still present on file transfer over a network
(albeit, on a slow network). I was trying to copy ~40MB file from home to work
computer using nautilus, the transfer got to about a quarter of the way, after
~10mins before it hung. Clicking cancel doesn't stop it, had to kill nautilus.
Doing 'scp' on the terminal takes ~16mins to complete the transfer.
Let me know if you'll want me to open another bug for this.
Comment 6 Alexander Larsson 2006-08-29 03:43:49 EDT
Hmmm. This might still be the inotify issue we had before, but the workaround
didn't help for network copies.

Upstream does have a real fix for the inotify sleep, but that is not built in
rawhide yet.
Comment 7 Alexander Larsson 2006-08-29 03:45:02 EDT
Did you copy from or to the local drive?
Comment 8 Deji Akingunola 2006-08-29 09:03:28 EDT
From the local drive.
Comment 9 Alexander Larsson 2006-08-30 09:01:27 EDT
Copying from a local drive to a remote share shouldn't cause the inotify
problems seen before, so this is likely another problem.

What exact type of share did you use? sftp:// ?
Comment 10 Deji Akingunola 2006-08-30 09:14:33 EDT
(In reply to comment #9)

> What exact type of share did you use? sftp:// ?
> 
Probably so. I created the connection with the 'ssh' option in connect to server.
Comment 11 Alexander Larsson 2006-08-30 10:59:58 EDT
I couldn't reproduce this with a local ssh copy. But this I think this is
clearly a different issue. Could you open a different bug, ideally with a bit
more information on your setup. Like, does this happen always? to all servers? etc

Note You need to log in before you can comment on or make changes to this bug.