Bug 20340 - agpgart resource allocation problem
agpgart resource allocation problem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-04 14:42 EST by Ed McKenzie
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 19:48:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ed McKenzie 2000-11-04 14:42:13 EST
Loading agpgart works the first time, but unloading and reloading it
results in the kernel finding the AGP aperture at 0x0. Obviously, starting
X with DRI after that leads to a hard freeze.

VIA MVP3 chipset, K6-2/400, Matrox G200 AGP, default RedHat 7.0 kernel. I
should add that I've yet to try a kernel (RH 2.2.14, stock 2.4.x-test,
etc.) that doesn't crash in this manner on my system.

I've filed bugs for this on dri.sourceforge.net as well as e-mails to lkml
and the agpgart maintainer, but to no avail. I suppose this isn't really an
interesting problem? The suggested fix seems to be to compile agpgart
static and be done with it, but that seems to me like a rather silly
solution.
Comment 1 Ed McKenzie 2001-02-21 16:36:24 EST
This bug is still present in Fisher. Obviously, the issue persists in 2.4 

kernels.



I think this could potentially be a problem for machines that boot in text by 

default and only use X occasionally -- agpgart would be removed after 

being unused for a period, and the next startx would lock the machine 

solid. I run gdm by default, so this is just idle speculation, but it's my 

feeling that this should be fixed.
Comment 2 Michael K. Johnson 2001-02-21 19:27:09 EST
Well, it could at least default to not being unloaded automatically...
Comment 3 Alan Cox 2001-02-21 19:41:06 EST
This problem should not been seen in recent -ac kernels
Comment 4 Michael K. Johnson 2001-02-21 19:48:55 EST
Ah, in that case, please upgrade to our latest beta kernel when it
is available (2.4.1-0.1.9 or later) and let us know whether or not
it fixes the problem.  Thanks!
Comment 5 Ed McKenzie 2001-03-15 12:27:38 EST
Fixed in 2.4.2-0.1.25 (and also in 2.4.2-ac19.)

Note You need to log in before you can comment on or make changes to this bug.