Bug 203406 - Change Config Channel name to be system name for local channels.
Change Config Channel name to be system name for local channels.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn420
All Linux
medium Severity medium
: ---
: ---
Assigned To: Grant Gainey
Preethi Thomas
:
Depends On:
Blocks: rhn500h-config-mgmt
  Show dependency treegraph
 
Reported: 2006-08-21 14:40 EDT by Ken Ganong
Modified: 2007-04-18 13:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn500h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 22:31:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ken Ganong 2006-08-21 14:40:10 EDT
The issue:
Localizing the names of local channels is difficult and requires awkward table
joins because the local config channel's are automatically created and populate
their name and label with English strings.

The solution:
Set the name of every local channel to the name of the system subscribed to it.
Set the label of every local channel to the id of the system subscribed to it.

The collateral:
There is a unique constraint on rhnConfigChannel for org_id, label, name
and there is a unique index for org_id, label.
Delete both of those and create a unique index for org_id, label, type_id.

The collateral reason:
First, both unique contraint and index existing is useless, the constraint will
always be true if the index allows it.
Second, there needs to be a type_id as part of the uniqueness. We are
automatically creating the local config channels, so if a user just happened to
create a global channel with the exact same label in the same org, our automatic
creation would never work, preventing a system from having a local channel.
Comment 1 Ken Ganong 2006-10-09 16:05:05 EDT
Changing status to modified for a bunch of my bugs.
Comment 2 Ken Ganong 2006-11-13 12:17:22 EST
Moving bugs to ON_DEV
Comment 3 Ken Ganong 2006-12-05 09:55:05 EST
Moving my bugs to ON_QA
Comment 4 Ken Ganong 2006-12-15 15:54:55 EST
Passing on my config management bugs to ggainey
Comment 5 Preethi Thomas 2007-01-11 10:53:26 EST
Marking verified as per conv with ggainey. 
Local Channels are  not displayed in the web UI anymore.
Comment 6 Preethi Thomas 2007-03-07 12:27:58 EST
verified in stage.
Comment 7 Brandon Perkins 2007-03-12 22:31:58 EDT
Closed in the rhn500h Release.

Note You need to log in before you can comment on or make changes to this bug.