Bug 203479 - ImportError: No module named AuditMsg
ImportError: No module named AuditMsg
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-21 19:04 EDT by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-21 23:43:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2006-08-21 19:04:22 EDT
Description of problem:
sudo /sbin/service setroubleshoot start
Starting setroubleshoot: Traceback (most recent call last):
  File "/usr/sbin/setroubleshootd", line 22, in ?
    from setroubleshoot.server import RunFaultServer
  File "/usr/lib/python2.4/site-packages/setroubleshoot/server.py", line 28, in ?
    from setroubleshoot.dispatcher import HandleAVCS
  File "/usr/lib/python2.4/site-packages/setroubleshoot/dispatcher.py", line 4, in ?
    import AuditMsg
ImportError: No module named AuditMsg
                                                           [FAILED]


Version-Release number of selected component (if applicable):
setroubleshoot-0.24-1

(am I missing a dependency?)
Comment 1 John Dennis 2006-08-21 23:43:04 EDT
Hi David:

Yes, it would appear you are missing audit-libs-python. I see this dependency is
missing from the spec file, I've corrected that and the change should appear in
the next rpm. If after installing audit-libs-python you still have a problem
please re-open this bugzilla. Thanks for testing and helping us!
Comment 2 Dave Malcolm 2006-08-22 17:41:46 EDT
Thanks.

Turned out I had audit-libs-python installed all along; I was only partially
up-to-date with rawhide.
audit-libs-python-1.2.1-1 didn't have the AuditMsg module

On upgrading to the latest (audit-libs-python-1.2.5-8) that module was supplied,
and the service started fine.

So theoretically you could change the requirement to need a specific version or
later, but since it will only affect FC6Test users I don't think this needs
fixing; leaving CLOSED.
Comment 3 John Dennis 2006-08-23 08:07:48 EDT
Dan, when I added the requires for audit-libs-python I didn't force a minimum
version because there was a minimum version on audit (see below). I mistakenly
assumed an update to a specific version of audit would force a matching update
of audit-libs* but apparently it doesn't. What is the minimum version we need
for audit-libs-python?

Requires: audit >= audit-1.2.5-7
Requires: audit-libs-python

Note You need to log in before you can comment on or make changes to this bug.