Bug 203488 - Hal or possible gnome-mount not correctly noticing LG branded usb drive
Hal or possible gnome-mount not correctly noticing LG branded usb drive
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-21 19:58 EDT by Jef Spaleta
Modified: 2013-03-05 22:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-18 13:33:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2006-08-21 19:58:54 EDT
Description of problem:
Hal on my up2date fc5 system is not correctly detecting my LG branded usb flash
drive, while other usb flash drives are detected

How reproducible:
always

Steps to Reproduce:
1. insert my LG flash drive
2. udev creates the appropriate sdX and sdX1 entries for the device and I can
mount the device as root with an explicit mount command on the cmdline
3. hal fails to correctly notice its a usb-storage device and does not inform
the gnome-desktop that this device is mountable, nor can I use gnome-mount on
the command line.

Expected results:
I should get an icon for my LG branded usb storage in the Computer window and it
should be user mountable like my memorex branded flash drive.

Additional info:
cat /proc/scsi/scsi
cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: ST3300822AS      Rev: 3.AA
  Type:   Direct-Access                    ANSI SCSI revision: 05
Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: ATA      Model: ST3808110AS      Rev: 3.AD
  Type:   Direct-Access                    ANSI SCSI revision: 05
Host: scsi3 Channel: 00 Id: 00 Lun: 00  <<<<< This Drive isn't user mountable
  Vendor: LG       Model: USB DRIVE        Rev: 2.00
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi4 Channel: 00 Id: 00 Lun: 00  <<<<< This Drive works as expected
  Vendor: Memorex  Model: TD Classic 003C  Rev: 1.04
  Type:   Direct-Access                    ANSI SCSI revision: 02


It's been a long time since I had to troubleshoot a hal hiccup so I've forgotten
how to coax more information out of hal. Please give me explicit system commands
to run to better determine where the failure is, I haven't had to troubleshoot
this sort of problem in the gnome-mount era of hal operation.

--jef
Comment 1 Jef Spaleta 2007-10-18 13:33:26 EDT
Closing, works on F7 now running 2.6.23.1-4.fc7 kernel

-jef

Note You need to log in before you can comment on or make changes to this bug.