Bug 203504 - User can no longer unmount hotpluggable storage media
User can no longer unmount hotpluggable storage media
Status: CLOSED DUPLICATE of bug 203073
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 01:24 EDT by Stefan Becker
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 11:33:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Becker 2006-08-22 01:24:56 EDT
Description of problem:
My FC5 installation just got updated to the KDE 3.5.4 packages released last
week. Now end users can't unmount hotpluggable storage media they mounted
themselves.

Version-Release number of selected component (if applicable):
kdelibs-3.5.4-0.1.fc5
kdebase-3.5.4-0.2.fc5

How reproducible:
Always

Steps to Reproduce:
1. Plug in USB storage device (I tried ext3 & vfat formatted ones)
2. Press OK on the mount dialog or double-click the storage media icon
3. Use "Safely remove" on the mounted storage media icon
  
Actual results:
Media stays mounted

Expected results:
Media should be unmounted

Additional info:
hal & selinux packages weren't updated so the changes in KDE 3.5.4 cause or have
unconvered the problem.

Only root can unmount those devices, because /etc/fstab doesn't get updated when
a hotpluggable storage media is connected. That might be the root problem and
therefore a hal problem if it is responsible to update /etc/fstab. I browsed
through the hal storage media scripts and it seems it doesn't update /etc/fstab
anywhere. The old(?) tools updfstab or fstab-sync do no longer exist in FC5.
Comment 1 Ngo Than 2006-08-22 11:33:44 EDT

*** This bug has been marked as a duplicate of 203073 ***

Note You need to log in before you can comment on or make changes to this bug.