Bug 203506 - Anaconda stalls after moving to step findrootparts (both text and graphic)
Anaconda stalls after moving to step findrootparts (both text and graphic)
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-08-22 01:58 EDT by George Walsh
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-02 14:45:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description George Walsh 2006-08-22 01:58:00 EDT
Description of problem:
System 'hangs' after reporting move to step findrootparts

Version-Release number of selected component (if applicable):

How reproducible:
I have attempted to install fc6.2 4 times with the same result. I have verified
the iso images with sha1sum and also the 5 cds themselves with your utility.
No problems encountered up to this point. I have attempted to install with both
text and graphical, and I have also tried the noacpi option at boot prompt.

The system includes 2 Pentium III processors, 512 mb ram, 5 x 10gb SCSI drives,
ADAPTEC 7896 adapter, onboard EtherExpress PRO/100+ and nic-card VT6105.
Graphics onboard Cirrus Logic GD 5480, sound SB0400 Audigy 2, driver: snd-emu10k1.

Currently running under Mandriva 2006 (Cooker).

Steps to Reproduce:
1.Anaconda reports "install exited abnormally [1/1]"
The installation log reports:
Starting graphical installation
Detected 512M of memory
Swap attempt of 512mb to 1024mb
(Warning) step installtype does not exist
(Warning) step complete does not exist
moving (1) to step welcome
moving (1) to step betanag
moving (1) to step findrootparts

2. The tail of the system message log (/tmp/syslog) shows:
INFO possible recursive locking detected
DWARF2 unwinder stuck at syscall_call+0x7/0xb
EIP: [<c0472670> ] shrink-dcache_for_umount_
SS: ESP 0068:dea05eb4

3. Cannot return to graphical installation screen with <F7>

NOTE: In the case of a text install, the following appears prior to the EIP: line:
WARNING /usr/lib/python2.4/site-packages/snack.py:250:
  Deprecation Warning: integer argument expected, got float
    self.w = _snack.scale(width,total).
Otherwise, the final diagnostic logged is the same as for a graphical install.
Actual results:
Cannot proceed further

Expected results:
A system install

Additional info:
Comment 1 Chris Lumens 2006-08-22 11:29:12 EDT
Looks like a kernel panic to me, so I'm reassigning it to them.  They'll need to
see the entire message so if you can attach pictures of the screen or transcribe
it all, that will be helpful.
Comment 2 George Walsh 2006-08-22 16:59:07 EDT
Tbis identical problem was reported at:


This should confirm the bug.

The problem with meeting your request for the 'entire message' lies with the
fact the log file (/tmp/X.log) disappears so I would apparently have no choice
but to key the whole thing in by hand. Is that correct? 

I'm willing to help if I can. I certainly like what I see and have enjoyed
reading through Jang's "Mastering Fedora Core 5" to help me break away from the
Mandriva mold which, at the present moment (their Beta 2) is a bit of a mess.

Please avise, and THANKS for the prompt response. That too impressed me.

Comment 3 George Walsh 2006-09-02 14:45:40 EDT
Since there is no response, I have decided to continue with Mandriva, whose 2007
(Cooker) is now working beautifully.

Note You need to log in before you can comment on or make changes to this bug.