Bug 203516 - Evolution desperately needs undo support
Evolution desperately needs undo support
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 05:11 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 17:37:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 207624 None None None Never

  None (edit)
Description Need Real Name 2006-08-22 05:11:50 EDT
Five years ago, "undo support" in evoltion was requested. It's still not started.

Web browsers use Ctrl+D to bookmark a page.
Evolution uses it to delete a message.

Get the wrong focus on the window, and you lose the message. Nice.

Please can we have this as an FCxTarget bug?
Comment 1 Matthew Barnes 2006-08-22 13:39:25 EDT
Is this bug about keybindings or are you requesting a new feature?
Comment 2 Need Real Name 2006-08-22 13:45:15 EDT
New feature; undo.
Comment 3 Matthew Barnes 2006-08-24 17:37:55 EDT
Let me suggest that you're probably not going to get very far by this avenue,
and that this is really an issue to take up with the upstream developers.  I
understand that you've encountered some upstream resistance to this feature
request, and I think it's because a stronger case needs to be presented for why
Evolution needs an "Undo" feature.

For starters, the developers need to see more use cases than just undoing a
deleted message.  While it's a good start, implementing "Undo" in an application
requires a fair amount of infrastructure to get right, especially if you want
multi-level "Undo" and "Redo" commands.  The application needs to not only keep
track of what you just did, but also how to reverse the operation.

If you really want to see this feature get in -- and you must if you've been
waiting over four years -- then I suggest coming up with list of as many use
cases as you can think of for what an "Undo" command would do in various
situations.  Like Jeff said, "what would undo do?"

It doesn't have to be technical.  Just list what the end user would see.  Maybe
express it in the form of:

    pre-condition -> action -> post-condition -> undo -> pre-condition

For example:

    Select messages in Inbox.  (pre-condition)
    Click Delete.  (action)
    Messages are moved to the Trash folder.  (post-condition)
    Select Undo.  (undo)
    Previously selected messages are moved back to Inbox.

There's probably another use case for the Junk button, as well as moving and
copying messages around, moving and renaming folders, changing your views,
flagging messages, etc.  Also think about what "Undo" might mean in other
components, like Calendar or Contacts, and come up with use cases for those too.

If other mailers such as Thunderbird implement "Undo", that would be a good
source to pull examples from.

Then, post your proposal to evolution-list@gnome.org and see what kind of
response you get.  If you can give enough compelling use cases for why Evolution
needs an "Undo" feature and how it would improve the user experience, and rally
support from enough users, you might motivate a developer to start thinking
about how to design the necessary infrastructure.

I'm afraid that's about all I can do for you.

Note You need to log in before you can comment on or make changes to this bug.