Bug 203537 - tail +n 2 su.log -> tail: cannot open `+n' for reading: No such file or directory
tail +n 2 su.log -> tail: cannot open `+n' for reading: No such file or direc...
Status: CLOSED DUPLICATE of bug 173431
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 07:47 EDT by Ehringer Eike
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 06:23:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ehringer Eike 2006-08-22 07:47:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727)

Description of problem:
When doing:
# tail +n 2 su.log
tail: cannot open `+n' for reading: No such file or directory
tail: cannot open `2' for reading: No such file or directory


Version-Release number of selected component (if applicable):
coreutils-5.96-1.2

How reproducible:
Always


Steps to Reproduce:
1. do the tail command with option +N
2.
3.

Actual Results:
tail does not work

Expected Results:
Refere to man pages:
If the first character of N (the number of bytes or lines) is a +, print beginning with the Nth item from the  start  of  each  file, otherwise, print the last N items in the file.

Additional info:
On FedoaraCore 4 with coreutils-5.2.1-48 -> tail works!
also AdvancedServer, Enterprise, HPUX 10.20-> 11.23, Sun, AIX -> tail works with same options...

Nearby, sort does also have a problem with the parameters!

-> All oure administrative scripts and tools fails on FC5!
Comment 1 Tim Waugh 2006-08-22 09:17:56 EDT

*** This bug has been marked as a duplicate of 203535 ***
Comment 2 Ehringer Eike 2006-08-24 05:37:17 EDT
Good morning,
i mean of course: # tail +2 su.log

e.g.:
# uname -a
HP-UX rbgs420x B.11.11 U 9000/800 1798937691 unlimited-user license

rooteieh:root @ IgniteSrv on rbgs420x  from RBG0J26C.ww011.siemens.net: 1812 
[ /tmp ]
# tail +2 vginfo.txt


e.g.
# tail +2 su.log
tail: cannot open `+2' for reading: No such file or directory

Comment 3 Ehringer Eike 2006-08-24 05:38:11 EDT
which is now the dublicate bug an what the real?
could you please mark one as GOOD - WORKING ONE?

thanks!
Comment 4 Tim Waugh 2006-08-24 06:23:57 EDT

*** This bug has been marked as a duplicate of 173431 ***

Note You need to log in before you can comment on or make changes to this bug.