Bug 203538 - a popt-devel package should be split out of popt
a popt-devel package should be split out of popt
Status: CLOSED DUPLICATE of bug 249352
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks: 226377
  Show dependency treegraph
 
Reported: 2006-08-22 07:49 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 12:00:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-08-22 07:49:32 EDT
Description of problem:

popt.h, static lib and .so should be in a -devel 
package.

Version-Release number of selected component (if applicable):


How reproducible: 


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2006-11-17 10:51:55 EST
Maybe it is the right time to make that change
such that it leaves time to workaround things that break?

The popt.3 man page should also be in -devel.
Comment 2 Jeff Johnson 2006-11-17 22:54:37 EST
Nothing will break, It Really Does'nt Matter. *shrug*
Comment 3 Patrice Dumas 2006-11-18 05:08:34 EST
repoquery --whatrequires libpopt.so.0
gives 225 results, so I guess some of them would have to add
a BuildRequires: popt-devel.
Comment 4 Jeff Johnson 2007-01-16 22:30:12 EST
popt is installed where rpm is installed. so libpopt.so.0 is guaranteed to be present when a *.spec parser 
is present.
Comment 5 Patrice Dumas 2007-01-17 05:23:20 EST
(In reply to comment #4)
> popt is installed where rpm is installed. so libpopt.so.0 is guaranteed to be
present when a *.spec parser 
> is present.

Indeed, and this is not my point. My point is that the devel parts of popt
should not be installed with the shared libs.

repoquery --whatrequires libpopt.so.0 is here only to give an idea of
what packages would need popt-devel as BuildRequires. rpm would figure
out the dependencies on sonames automatically anyway.
Comment 6 Jeff Johnson 2007-01-17 12:01:18 EST
Then your
    rpm -q --whatrequires libpopt.so.0 | wc -l
test is flawed, what really needs to be (and is not adequately imho)
tracked is which dependencies are needed by -devel and which are
needed for functioning non-devel packages.

No matter what, you're in for largish package rebuilding, hardly worth
the effort to be conformant with a
    Though shalt put the libfoo.so -> ... symlink in a -devel package.

The popt package contains 36 files:
    30 LC_MESSAGES catalogs
     1 man page
     1 static library
     1 include file
     1 shared library
     2 symlinks
and you wish to move 2 (or perhaps the man page too) into a -devel package.

Go fer it! Get rid of the static library while you're at it, FC has already removed libpopt.la ...
Comment 7 Patrice Dumas 2007-01-17 12:36:21 EST
(In reply to comment #6)
> Then your
>     rpm -q --whatrequires libpopt.so.0 | wc -l
> test is flawed, 

It is only to give a rough idea of the number of packages impacted by 
a split of popt-devel.

> what really needs to be (and is not adequately imho)
> tracked is which dependencies are needed by -devel and which are
> needed for functioning non-devel packages.

That's the point in splitting every packages in a -devel and a non-devel 
part. It is almost done at the level of fedora. It is already done for 
fedora extras, since it is a must item in the guidelines, and it should 
be done anyway during the review of core packages for the merge.

> No matter what, you're in for largish package rebuilding, hardly worth
> the effort to be conformant with a
>     Though shalt put the libfoo.so -> ... symlink in a -devel package.

It is certainly painful, and not a vital need. However moving
-devel stuff to a subpackage ensures that only the packages requiring
explicitly the -devel package (be it indirectly) ends up with the possibility
to link against that package in the buildroot. It helps doing reproducible
builds. Moreover it is a prerequisite to have multilib enabled -devel 
packages.

> The popt package contains 36 files:
>     30 LC_MESSAGES catalogs
>      1 man page
>      1 static library
>      1 include file
>      1 shared library
>      2 symlinks
> and you wish to move 2 (or perhaps the man page too) into a -devel package.

Yes, the man page is also for -devel. The size of the -devel (or main) 
package isn't really important, in my opinion, the split is done for the
reasons exposed above, the packages sizes don't matter. An added benefit
is that it reduces the size of non devel packages, though admitedly for 
popt the gain is low, and negligible if the static lib is removed.

> Go fer it! Get rid of the static library while you're at it, FC has already
removed libpopt.la ...

I am personally against removing the static libraries. There is 
a great pressure in fedora to remove them, but it is a separate 
issue.
Comment 8 Patrice Dumas 2007-07-31 12:00:22 EDT

*** This bug has been marked as a duplicate of 249352 ***

Note You need to log in before you can comment on or make changes to this bug.