Bug 203565 - split out kpathsea devel + moves from tetex-fonts?
split out kpathsea devel + moves from tetex-fonts?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 10:33 EDT by Patrice Dumas
Modified: 2013-07-02 19:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-09 08:49:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-08-22 10:33:10 EDT
Description of problem:

the kpathsea include files and libkpathsea.a should certainly be
in their own package, which could be named, for example 
kpathsea-devel. Having this library mixed with fonts is in my 
opinion quite messy.

It is not obvious where the kpathsea.info and web2c.info info
pages should go, but maybe they could be better in tetex-doc
or tetex. It's not obvious, though. 

the k* and texhash programs could also be in tetex, but it's 
also debatable, I guess. Indeed it could be cleaner to 
have only things related to fonts in tetex-fonts, and no generally
usefull stuff. Not a big deal.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2006-11-19 13:33:19 EST
These issues are still relevant, but maybe it is not worth
fixing them in tetex given that we are switching to texlive?
This should be taken into account in the texlive packaging,
but since I guess it'll go through a formal review those kind
of issue will certainly be spotted and debated.
Comment 2 Jindrich Novy 2007-06-11 10:36:52 EDT
The new TeXLive packages the kpathsea-devel separately. It is now under review.

For more information see:
http://fedoraproject.org/wiki/Releases/FeatureTexLive
Comment 3 Jindrich Novy 2007-12-09 08:49:29 EST
This is now fixed in rawhide as tetex was replaced by texlive recently.

Note You need to log in before you can comment on or make changes to this bug.