Bug 203568 - split out a -devel package for libsmbclient
split out a -devel package for libsmbclient
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks: 226387
  Show dependency treegraph
 
Reported: 2006-08-22 10:46 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 07:42:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-08-22 10:46:26 EDT
Description of problem:

The headers, .so and .a of smbclient should be in a -devel 
package. 

As a side note
/usr/include/libmsrpc.h
includes header files that are not present. Maybe it shouldn't
be shipped?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jay Fenlason 2006-10-30 14:18:08 EST
Moving to devel for fc7. 
Comment 2 Patrice Dumas 2006-11-17 11:09:27 EST
Maybe it is the right time to make that change
such that it leaves time to workaround things that break?

Things will break (except for samba-common itself) 
since there is:

$ repoquery --whatrequires libsmbclient.so.0
gnome-vfs2-smb-0:2.16.2-2.fc7.i386
kdebase-6:3.5.5-0.4.fc6.i386
xine-lib-0:1.1.2-17.fc7.i386
samba-common-0:3.0.23c-2.i386
Comment 3 Dmitry Butskoy 2007-04-25 07:38:26 EDT
Whether this can be closed now?
Comment 4 Patrice Dumas 2007-04-25 07:42:47 EDT
Looks like it is fixed now.

Note You need to log in before you can comment on or make changes to this bug.