Bug 203573 - Do not ship libscrollkeeper.a or libscrollkeeper.so
Do not ship libscrollkeeper.a or libscrollkeeper.so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scrollkeeper (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 10:58 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: scrollkeeper-0.3.14-9.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 22:04:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-08-22 10:58:21 EDT
Description of problem:

The .so and .a should be in a -devel package. Or maybe not shipped
at all since there is no header.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Barnes 2006-10-30 16:28:39 EST
It looks like some of the scrollkeeper utilities dynamically link to
libscrollkeeper.so.0.

   $ ldd /usr/bin/scrollkeeper* | grep scrollkeeper

Does that not mean the .so needs to be packaged with the binaries?

I agree that I don't see much point in shipping libscrollkeeper.a.
Comment 2 Patrice Dumas 2006-10-30 16:51:52 EST
Indeed, but not against the /usr/lib/libscrollkeeper.so link.
It is only needed at build time, so should be in -devel.

If all that links against libscrollkeeper is in the 
scrollkeeper source package then the .so is no needed for them.
And the lack of headers certainly shows that it is not meant
to be linked against by programs outside of the scrollkeeper
package itself.
Comment 3 Matthew Barnes 2006-10-30 17:24:18 EST
Ah, I see.  Indeed there seems to be no packages requiring the .so or .a.

    $ repoquery --whatrequires libscrollkeeper.a
    $ repoquery --whatrequires libscrollkeeper.so
    $ repoquery --whatrequires libscrollkeeper.so.0
    scrollkeeper-0:0.3.14-8.fc6.i386

So a -devel package does not make sense.  I think I'd prefer to just not ship
those files.  Changing the summary appropriately.
Comment 4 Matthew Barnes 2006-10-30 22:03:01 EST
Fixed in scrollkeeper-0.3.14-9.fc7.

Note You need to log in before you can comment on or make changes to this bug.