Bug 2036045 - Import flow: Resource limit form validation doesn't work reliable
Summary: Import flow: Resource limit form validation doesn't work reliable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.9
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.8.z
Assignee: Debsmita Santra
QA Contact: Mohammed Saud
URL:
Whiteboard:
Depends On: 2036044
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-29 13:17 UTC by OpenShift BugZilla Robot
Modified: 2022-02-01 12:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-01 12:44:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 10788 0 None open [release-4.8] Bug 2036045: fix resource limit form validation 2022-01-06 19:14:54 UTC
Red Hat Product Errata RHBA-2022:0278 0 None None None 2022-02-01 12:44:50 UTC

Internal Links: 2031082

Description OpenShift BugZilla Robot 2021-12-29 13:17:24 UTC
+++ This bug was initially created as a clone of Bug #2036044 +++

Created attachment 1848211 [details]
invalid form validation

Description of problem:

When the user creates a Deployment with one of the Import from ... pages, she or he has the option to define a resource limit in the advanced option section.

The resource limit section allows the user to define Request and Limit CPU cycles and Request and Limit memory. The form does not allow a limit value which is smaller then the request value.

This form sometimes shows unexpected validations error if a unit is selected. It looks like that the unit is ignored when the number is changed.

See attached video.

Prerequisites (if any, like setup, operators/versions):
None

Steps to Reproduce
1. Switch to developer perspective
2. Add > Import from Git
3. Scroll down to Advanced options and click on Resource limits
4. Enter test data into the Resource limits forms
  1. Broken case a)
    1. 10 request CPU, keep millicores
    2. 15 limit CPU, keep millicores
    3. Switch limit to cores
    4. Press Limit minus button until the value is below 10.
  2. Broken case b)
    1. 91 request CPU, keep millicores
    2. 2 limit CPU, select cores
    3. Press Limit plus button until value is 5
    4. Press Resource plus button until value is 6

Actual results:
It shows invalid form validation errors

Expected results:
It should not show form validation errors in that case

Reproducibility (Always/Intermittent/Only Once):
Always

Build Details:
4.9 master (19c0a653cc420c4ecee6ca44bd1126b2ee06d6ed)

--- Additional comment from dsantra on 2021-12-29 13:11:35 UTC ---

The JIRA bug was verified by Saud (https://issues.redhat.com/browse/ODC-6122)

Verified on:
Build: 4.9.0-0.nightly-2021-07-21-081948
Browser: Firefox 90

Comment 5 Mohammed Saud 2022-01-28 11:22:23 UTC
Verified on:
Version: 4.8.0-0.nightly-2022-01-27-180909
Browser: Firefox 96

Comment 7 errata-xmlrpc 2022-02-01 12:44:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.29 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0278


Note You need to log in before you can comment on or make changes to this bug.