Bug 2036121 - cachelib doesn't build on aarch64
Summary: cachelib doesn't build on aarch64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cachelib
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ARM
TreeView+ depends on / blocked
 
Reported: 2021-12-29 19:26 UTC by Michel Alexandre Salim
Modified: 2022-03-26 15:26 UTC (History)
4 users (show)

Fixed In Version: cachelib-16^20220314gitbd22b0e-1.fc37 cachelib-16^20220314gitbd22b0e-2.fc35 cachelib-16^20220314gitbd22b0e-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-20 06:42:35 UTC
Type: Bug


Attachments (Terms of Use)
Build log on aarch64 (219.16 KB, text/plain)
2021-12-29 19:26 UTC, Michel Alexandre Salim
no flags Details

Description Michel Alexandre Salim 2021-12-29 19:26:42 UTC
Created attachment 1848265 [details]
Build log on aarch64

Created attachment 1848265 [details]
Build log on aarch64

Description of problem:
Note: will reassign to cachelib once it's available on Bugzilla, but need to file this to properly block on the AArch64 tracker

cachelib fails to build on aarch64 with the following error (full build log attached):


```
/builddir/build/BUILD/CacheLib-e3703aade03d359d290936b334ab81ca4a856b41/cachelib/allocator/CacheStats.cpp: In member function 'void facebook::cachelib::detail::Stats::populateGlobalCacheStats(facebook::cachelib::GlobalCacheStats&) const':
/builddir/build/BUILD/CacheLib-e3703aade03d359d290936b334ab81ca4a856b41/cachelib/allocator/CacheStats.cpp:51:33: error: conversion from 'SizeVerify<15968>' to non-scalar type 'SizeVerify<16160>' requested
   51 |   SizeVerify<sizeof(Stats)> a = SizeVerify<15968>{};
      |                                 ^~~~~~~~~~~~~~~~~~~
```

Version-Release number of selected component (if applicable):
cachelib-16-1.20211129gite3703aa.fc36

How reproducible:
Uncertain. Worked fine during review, will investigate later.

Steps to Reproduce:
1. fedpkg clone cachelib
2. git checkout 88720bff603d75be2ce7fc293b85156004dec2ae
3. fedpkg --release rawhide srpm
4. koji build --scratch --arch-override=aarch64 rawhide ./cachelib*.src.rpm


Actual results:
Build fails

Expected results:
Build succeeds as on x86_64 and ppc64le

Additional info:

Comment 1 Peter Robinson 2021-12-31 07:44:11 UTC
Has this been reported upstream, it looks like an actual upstream bug.

Comment 2 Fedora Update System 2022-03-17 20:54:08 UTC
FEDORA-2022-ea72efb8d1 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-ea72efb8d1

Comment 3 Fedora Update System 2022-03-18 20:08:15 UTC
FEDORA-2022-ea72efb8d1 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-ea72efb8d1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-ea72efb8d1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2022-03-20 06:36:52 UTC
FEDORA-2022-4cea2ebe6c has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-4cea2ebe6c

Comment 5 Fedora Update System 2022-03-20 06:38:20 UTC
FEDORA-2022-e35ee9fa26 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-e35ee9fa26

Comment 6 Fedora Update System 2022-03-20 06:42:35 UTC
FEDORA-2022-e35ee9fa26 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Fedora Update System 2022-03-21 02:53:40 UTC
FEDORA-2022-4cea2ebe6c has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-4cea2ebe6c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-4cea2ebe6c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-03-25 23:15:54 UTC
FEDORA-2022-ea72efb8d1 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2022-03-26 15:26:28 UTC
FEDORA-2022-4cea2ebe6c has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.