Bug 2036137 - python-psutil-5.9.1 is available
Summary: python-psutil-5.9.1 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-psutil
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Infrastructure SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 2051781 2054094 2089548 2112518
TreeView+ depends on / blocked
 
Reported: 2021-12-29 21:48 UTC by Upstream Release Monitoring
Modified: 2022-08-18 19:29 UTC (History)
7 users (show)

Fixed In Version: python-psutil-5.9.1-1.fc38 python-psutil-5.9.1-1.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-18 18:26:22 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 5.9.0 (#2036137) (1.05 KB, patch)
2021-12-29 21:48 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2021-12-29 21:48:35 UTC
Latest upstream release: 5.9.0
Current version/release in rawhide: 5.8.0-12.fc36
URL: https://github.com/giampaolo/psutil

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/3978/

Comment 1 Upstream Release Monitoring 2021-12-29 21:48:40 UTC
Created attachment 1848279 [details]
Update to 5.9.0 (#2036137)

Comment 2 Upstream Release Monitoring 2021-12-29 21:55:19 UTC
the-new-hotness/release-monitoring.org's scratch build of python-psutil-5.9.0-1.fc34.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=80617783

Comment 3 Upstream Release Monitoring 2022-05-20 20:10:57 UTC
Latest upstream release: 5.9.1
Current version/release in rawhide: 5.8.0-13.fc36
URL: https://github.com/giampaolo/psutil

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/3978/

Comment 4 Upstream Release Monitoring 2022-05-20 20:11:00 UTC
Scratch build failed. Details below:

BuilderException: Build started, but failure happened during post build operations:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-hbgryvwg/python-psutil.spec']' returned non-zero exit status 1.

StdOut:
error: Bad source: ./psutil-5.9.1.tar.gz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.9/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.9/site-packages/hotness/builders/koji.py", line 188, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 5 Major Hayden 🤠 2022-06-24 15:19:27 UTC
It would be super handy to get this updated as azure-cli is asking for psutil~=5.9.0 in the requirements now. I'll try to propose a PR if I can get some time.

Comment 6 Jonathan Wright 2022-07-31 06:25:41 UTC
I've submitted a PR for the update.

https://src.fedoraproject.org/rpms/python-psutil/pull-request/19

Comment 7 Kevin Fenzi 2022-07-31 18:48:07 UTC
The i686 tests seem to be hanging... but might be just a race condition (we have seen that before)

Comment 8 Fedora Update System 2022-08-18 18:23:19 UTC
FEDORA-2022-37133589ab has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-37133589ab

Comment 9 Fedora Update System 2022-08-18 18:26:22 UTC
FEDORA-2022-37133589ab has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2022-08-18 19:27:59 UTC
FEDORA-2022-2f7408afdb has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-2f7408afdb

Comment 11 Fedora Update System 2022-08-18 19:29:22 UTC
FEDORA-2022-2f7408afdb has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.