Bug 203625 - Anaconda freezes on DHCP dns-domain option with more than 1 domain name present
Anaconda freezes on DHCP dns-domain option with more than 1 domain name present
Status: CLOSED DUPLICATE of bug 201907
Product: Fedora
Classification: Fedora
Component: libdhcp (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 15:16 EDT by Doug Ledford
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 10:40:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Ledford 2006-08-22 15:16:36 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Configure dhcp with option dns-domain "domain1 domain2";
2. Attempt install that uses network and dhcp configuration
3.
  
Actual results: Anaconda goes into an infinite loop that you can't break out of


Expected results: Reverse host name lookup should succeed and proceed from there


Additional info: The syntax for dns-domain that is listed above, while not
strictly correct, is handy for passing a complete search list of domains to dhcp
clients instead of a single domain.  This syntax works 100% under Fedora Core
once the installation is done, it only fails under anaconda.  Mac OS X doesn't
quite handle it right, but oh well.  Windows XP is hard to tell, I'm not sure it
ever uses domain search information from the dhcp server.
Comment 1 David Cantrell 2006-11-02 10:40:58 EST
This problem was fixed in libdhcp-1.16.

*** This bug has been marked as a duplicate of 201907 ***

Note You need to log in before you can comment on or make changes to this bug.