Bug 203633 - libopal.so should be in -devel
libopal.so should be in -devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: opal (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 15:41 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 11:26:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-08-22 15:41:51 EDT
Description of problem:

libopal.so should be in -devel

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Veillard 2006-08-22 16:10:16 EDT
Huh ? can you justify ?

you should not need opal-devel to run ekiga ... That sounds quite wong.
I assume it's an error considering the complete lack of justification and
weirdness from an engineering practice.

Daniel
Comment 2 Patrice Dumas 2006-08-22 16:33:57 EDT
I may be quite wrong, and it is really possible that libopal.so
should be in the main package. But in general the .so file like
libopal.so are only needed when linking, not at runtime, 
and should therefore be in the -devel package and not in the 
main package. There are exception (like dlopening, although
it is ugly), but I don't think there is such an exception for
ekiga, since there is
ldd /usr/bin/ekiga | grep opal
        libopal_linux_x86_r.so.2.2 => /usr/lib/libopal_linux_x86_r.so.2.2
(0x0444b000)

and I verified that ekiga seems to launch when there is no 
/usr/lib/libopal.so

rpmling gives a warning:

 rpmlint opal
E: opal obsolete-not-provided openh323
W: opal devel-file-in-non-devel-package /usr/lib/libopal.so
W: opal devel-file-in-non-devel-package /usr/lib/libopal_linux_x86_r.so

the second warning (about libopal_linux_x86_r.so) seems wrong, but the
one about libopal.so seems valid.

Having the .so in the main package is not right, since it is possible
to link without -devel package installed (although it may be improbable,
depending on the case).

On 
http://fedoraproject.org/wiki/Packaging/ReviewGuidelines
there is a
- MUST: If a package contains library files with a suffix (e.g. libfoo.so.1.1),
then library files that end in .so (without suffix) must go in a -devel package.
I admit it doesn't cover exactly that case, since there is no suffix, 
but a library name with something between the name and the .so 
(in libopal_linux_x86_r.so) but I think it applies here anyway.

Is there a good reason for libopal.so to be in the main package and
not in -devel?
Comment 3 Daniel Veillard 2006-08-22 16:52:50 EDT
Okay, not seeing the rules I wqas wondering where this was coming from

paphio:~ -> rpm -qf /usr/lib/libxslt.so
libxslt-devel-1.1.16-1
paphio:~ -> rpm -qf /usr/lib/libxml2.so
libxml2-devel-2.6.26-2

I assume this was borken in the opal spec, okay this need fixing then.
Please give context when you create the bug reports, thanks.

Daniel
Comment 4 Patrice Dumas 2006-08-22 16:57:38 EDT
Sorry for the terse bugreport but I filled 31 bugs like
this one, this is a bit boring :/
Comment 5 Daniel Veillard 2006-11-06 11:26:52 EST
okay I pushed opal-2.2.3-3.fc7 with the fix, it should show in rawhide soonish,

  thanks !

Daniel

Note You need to log in before you can comment on or make changes to this bug.