Bug 2036371 - Please build cura 4.12.1 for Fedora
Summary: Please build cura 4.12.1 for Fedora
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cura
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-12-31 13:26 UTC by Jan Pazdziora
Modified: 2022-03-15 00:07 UTC (History)
5 users (show)

Fixed In Version: cura-4.13.1-2.fc34 cura-4.13.1-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-14 22:25:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan Pazdziora 2021-12-31 13:26:43 UTC
Description of problem:

It seems Cura 4.12.1 was released on 2021-11-18: https://github.com/Ultimaker/Cura/releases/tag/4.12.1.

Please consider packaging it for Fedora.

Version-Release number of selected component (if applicable):

cura as packaged in Fedora 35.

How reproducible:

Deterministic.

Steps to Reproduce:
1. dnf install cura-4.12.1

Actual results:

No match for argument: cura-4.12.1
Error: Unable to find a match: cura-4.12.1

Expected results:

Installation of cura 4.12.1 passes.

Additional info:

Comment 1 Jan Pazdziora 2022-01-01 14:44:06 UTC
I've also noticed that the current cura-4.11.0-1.fc35.noarch installation suffers from https://github.com/Ultimaker/Cura/issues/10785 -- when support blocker is used, clicking on the model results in the same traceback as in the GitHub issue.

Comment 2 Gabriel Féron 2022-01-01 18:11:58 UTC
Thanks, the update PR is waiting for a final review now: https://src.fedoraproject.org/rpms/cura/pull-request/13

Comment 3 Bernhard Furtmueller 2022-01-01 18:32:20 UTC
Gabriel, isn't there a PR missing for libarcus? Or will that one be created if everything else is ready for final?

Comment 4 Gabriel Féron 2022-01-01 18:37:19 UTC
Good point, I just forgot to open the PR from the branch I pushed a while ago: https://src.fedoraproject.org/rpms/libarcus/pull-request/19

Comment 5 Fedora Update System 2022-01-01 22:10:42 UTC
FEDORA-2022-b5207bc9c2 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-b5207bc9c2

Comment 6 Fedora Update System 2022-01-01 22:11:23 UTC
FEDORA-2022-d894a07b78 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-d894a07b78

Comment 7 Fedora Update System 2022-01-01 22:12:58 UTC
FEDORA-2022-162f70a9db has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2022-01-02 01:09:26 UTC
FEDORA-2022-d894a07b78 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-d894a07b78`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-d894a07b78

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2022-01-02 01:21:12 UTC
FEDORA-2022-b5207bc9c2 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-b5207bc9c2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-b5207bc9c2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Jan Pazdziora 2022-01-02 08:20:38 UTC
Thanks for the builds. I confirm that on Fedora 35, cura 4.12.1 seems to work reasonably well.

The https://github.com/Ultimaker/Cura/issues/10785 is still present though. Since in the comments of that issues it was pointed out that it might be due to Qt being too new, is that something that Fedora builds might want to carry as a compatibility patch, before 4.13 is out?

Comment 11 Miro Hrončok 2022-01-02 08:38:04 UTC
If you open a PR with the patch, I'll gladly review and merge. Otherwise, I will eventually get to it.

Comment 12 Gabriel Féron 2022-01-02 12:59:00 UTC
Opened PR https://src.fedoraproject.org/rpms/cura/pull-request/14 with the relevant patch.

Comment 13 Fedora Update System 2022-01-02 21:30:09 UTC
FEDORA-2022-b5207bc9c2 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-b5207bc9c2

Comment 14 Miro Hrončok 2022-01-02 21:30:36 UTC
(In reply to Gabriel Féron from comment #12)
> Opened PR https://src.fedoraproject.org/rpms/cura/pull-request/14 with the
> relevant patch.

Added to rawhide and the F35 update https://bodhi.fedoraproject.org/updates/FEDORA-2022-b5207bc9c2

Comment 15 Fedora Update System 2022-01-03 01:45:55 UTC
FEDORA-2022-b5207bc9c2 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-b5207bc9c2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-b5207bc9c2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2022-02-03 13:16:57 UTC
FEDORA-2022-b32cb71cc2 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-b32cb71cc2

Comment 17 Fedora Update System 2022-02-03 13:17:53 UTC
FEDORA-2022-252d889047 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-252d889047

Comment 18 Fedora Update System 2022-02-04 02:14:48 UTC
FEDORA-2022-252d889047 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-252d889047`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-252d889047

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2022-02-04 02:27:30 UTC
FEDORA-2022-b32cb71cc2 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-b32cb71cc2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-b32cb71cc2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2022-03-14 22:25:25 UTC
FEDORA-2022-252d889047 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 21 Fedora Update System 2022-03-15 00:07:12 UTC
FEDORA-2022-b32cb71cc2 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.