Bug 203643 - Radeon 9800 (r300) no longer gets accelerated 3D
Radeon 9800 (r300) no longer gets accelerated 3D
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-22 16:16 EDT by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 18:20:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dropped PATCh, whose dropping causes the descrived problems (617 bytes, patch)
2006-08-22 16:16 EDT, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2006-08-22 16:16:23 EDT
Description of problem:
Running a 3D apps no longer uses hw accel 3D / DRI:
[hans@shalem ~]$ glxgears
Radeon 9500/9700/9800 cards are not currently stable.
More details can be found at https://bugs.freedesktop.org/show_bug.cgi?id=6318
libGL warning: 3D driver returned no fbconfigs.
libGL error: InitDriver failed
libGL error: reverting to (slow) indirect rendering

Version-Release number of selected component (if applicable):
mesa-libGL-6.5-22.20060818cvs.fc6

Additional info:
I did a diff between this version and my own CVS build and this problem is that
the mesa-6.5-force-r300.patch has been dropped while upgrading to CVS, but this
patch is still needed to get hw accel 3D / DRI on my 9800. I don't see why this
still should be disabled by default as it works fine (and I've tried lots of games).

The dropped patch was in the previous rawhide builds, so I assume you still have
it, but I'm attaching it just to be sure.
Comment 1 Hans de Goede 2006-08-22 16:16:25 EDT
Created attachment 134668 [details]
Dropped PATCh, whose dropping causes the descrived problems
Comment 2 Adam Jackson 2006-08-22 18:20:52 EDT
So, I dropped it because it no longer applied and I didn't see the getenv in a
grep, but clearly I was on drugs.  Fixed in 6.5-25*, thanks!

Note You need to log in before you can comment on or make changes to this bug.