Bug 203667 - [PATCH] enhance system-config-rootpassword interface (Fedora Usability)
[PATCH] enhance system-config-rootpassword interface (Fedora Usability)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-rootpassword (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2006-08-22 17:55 EDT by Damien Durand
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 06:14:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to enhance system-config-rootpassword interface (8.56 KB, patch)
2006-08-22 17:55 EDT, Damien Durand
no flags Details | Diff

  None (edit)
Description Damien Durand 2006-08-22 17:55:45 EDT
Hi,

The Fedora Usability team has made a patch for the system-config-rootpassword
tool. With this patch, the utility is more intuitive and sexy ;-)
You can take a look with this gif file :
http://glive.tuxfamily.org/blog/images/system-config-rootpassword2.gif


Thanks in advance

Damien Durand and the Fedora Usability team
Comment 1 Damien Durand 2006-08-22 17:55:49 EDT
Created attachment 134681 [details]
Patch to enhance system-config-rootpassword interface
Comment 2 Dave Malcolm 2006-08-22 18:06:35 EDT
I can't comment on the code quality, but the text needs a little revision.
Suggest changing at least:
from:
  "You can change the root password in filling \nthe following fields:"
to:
  "You can change the root password by filling \nthe following fields:"

from:
  "the fields are not the same, please filling \nagain"
to:
  "The two fields did not match.  Please try \nagain"

etc.  (Maybe reuse the old text, if it's already been translated)
Comment 3 Damien Durand 2006-08-22 18:26:33 EDT
Thank you for your comments, the labels are fixed by this new path :
http://glive.tuxfamily.org/code/new_system_config_root_password2.patch

For the old text, I think, it's not really coherent with the new interface,
tooltips etc... but yeah that can be a problem with the translation teams.

Regards,

Damien

Comment 4 Haïkel Guémar 2006-08-23 04:29:52 EDT
Just one thing, in the demo, when the pass-o-meter show the strong but the
tooltip says that it's based on a reversed dictionnary word, it was because the
tooltip was not updated. It had been fixed in the patch.
A password is only considered as strong when it is long enough (the limit was
put at 8 caracters) and it validates the cracklib test. Well it had a new
dependency in the rpm, but cracklib is already in core as a dependence of pam.
The pass-o-meter is only here to give a feedback to "average" end-users and not
sysadmins.
Comment 5 Damien Durand 2006-08-28 06:55:05 EDT
Ping?
Comment 6 Luke Macken 2006-09-10 16:58:11 EDT
In your animation, the 'Change root password' button become enabled while typing
the password a second time, before the second password is even the same length
as the first.   This should probably be fixed.
Comment 7 Paul Nasrat 2006-10-30 06:14:21 EST
Sorry for the delay - I've commited this to HEAD with a small change to address
Comment #6.

Will be in rawhide shortly.
Comment 8 Damien Durand 2006-10-30 06:53:33 EST
I'm really happy, thanks you for your devoted time ;-)

Note You need to log in before you can comment on or make changes to this bug.